awesome

Welcome to awesome bug tracking system.
Tasklist

FS#1012 - IntelliJ IDEA hangs while importing maven project, awesome-only

Attached to Project: awesome
Opened by Anton (zhuravlik) - Saturday, 30 June 2012, 11:24 GMT
Last edited by Uli Schlachter (psychon) - Friday, 06 July 2012, 18:26 GMT
Task Type Bug Report
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity High
Priority Normal
Reported Version git/master
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

There is the problem with AWT event queue when using awesome WM:
java.awt.EventQueue.dispatchEvent may hang.

It is reproducible stably with IntelliJ IDEA.


Steps to reproduce with IDEA:
create new project -> import from external model -> maven -> specify project data -> click Next button -> hang

I cannot reproduce this bug with openbox WM.

It seems to appear at the same time as problems with MATLAB (FS#971, FS#972,  FS#973 ), which I can confirm.
Unfortunately, I do not remember between which builds of awesome they appeared.

~ % awesome -version
awesome v3.4-732-g1de4134 (Closing In)
Build: Jun 30 2012 14:55:45 for x86_64 by gcc version 4.7.1 (anton@zhuravlik)
Compiled against Lua 5.1.5 (running with Lua 5.1)
D-Bus support: รข

~ % uname -a
Linux zhuravlik 3.4.4-2-ARCH #1 SMP PREEMPT Sun Jun 24 18:59:47 CEST 2012 x86_64 GNU/Linux


Related issue in IDEA bugtracker:
http://youtrack.jetbrains.com/issue/IDEA-87251

If you are sure it is Java platform bug, plz let me know, I'll try to investigate the issue further.
This task depends upon

Closed by  Uli Schlachter (psychon)
Friday, 06 July 2012, 18:26 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Reporter claims this is a duplicate of  FS#973 
Comment by Uli Schlachter (psychon) - Saturday, 30 June 2012, 13:16 GMT
If this really is a relatively new issue, I'd like to ask you for a git bisect to figure out what exactly caused this.

You only changed awesome version, right? So nothing changed on the java side?

On your question: If awesome would be hanging, that would sound a lot like a bug in awesome. So if Intellij IDEA is hung... :-)
Comment by Anton (zhuravlik) - Saturday, 30 June 2012, 14:25 GMT
>If this really is a relatively new issue, I'd like to ask you for a git bisect to figure out what exactly caused this.
>You only changed awesome version, right? So nothing changed on the java side?

It is with us at least from the beginning of June, when I first time experienced this issue.

Ok, at first I'll check awesome/IDEA/java versions on my previous laptop, where this bug was not present.
It seems that there were java and IDEA updates between that, not only awesome updates.

Then I'll travel between several revisions and check when this bug appeared.

>On your question: If awesome would be hanging, that would sound a lot like a bug in awesome. So if Intellij IDEA is hung... :-)

Yes, but why it does not hang on openbox? :)
And other Java apps, say MATLAB, behave differently on openbox (menus are working, clicks are always working) and awesome (menus close themselves after they are opened, clicks only select controls but the click is not passed to it).

It seems that there is something with focus events, which is the root of all these problems. But, of course, it may be a Java problem.
Comment by Anton (zhuravlik) - Saturday, 30 June 2012, 16:51 GMT
Issue was introduced somewhere between May 8 (g1730d4f) and June 10.
Will try to figure out something from commit log and try to bisect.
Comment by Anton (zhuravlik) - Saturday, 30 June 2012, 17:01 GMT
Yes, with previous IDEA build which was ok on the machine with g1730d4f, on current machine there is the same hang.
Comment by Anton (zhuravlik) - Saturday, 30 June 2012, 18:10 GMT
No, I was not right, I did not use this feature of IDEA since a bit earlier moment.

This issue appeared between March, 09 and April, 22.

I confirm that I cannot reproduce issue with March build and reproduce it with April build.
On my old laptop, under same other conditions.
Comment by Anton (zhuravlik) - Saturday, 30 June 2012, 18:15 GMT
Between those dates, there were two commits which played games with focus:

http://git.naquadah.org/?p=awesome.git;a=commit;h=819daca18c9ad25493e3e7023dd5b107b79683cd
Focus history: Don't ignore unfocusable clients

http://git.naquadah.org/?p=awesome.git;a=commit;h=ba64f3c3cd9e1cded99e1677ee6aa21cfa3cd078
client_focus_refresh: Always set input focus

I will try to undo each of them and note if issue was fixed.
Comment by Anton (zhuravlik) - Saturday, 30 June 2012, 18:20 GMT
And yes, it has the same roots as  FS#973 , because problems with MATLAB disappeared after that rollback, too.
Comment by Anton (zhuravlik) - Saturday, 30 June 2012, 18:35 GMT
Something is wrong in the state of Denmark.

After undoing the changes of commit http://git.naquadah.org/?p=awesome.git;a=commit;h=ba64f3c3cd9e1cded99e1677ee6aa21cfa3cd078 both IDEA and MATLAB issues are gone.
Please check what is wrong with it.
Comment by Uli Schlachter (psychon) - Saturday, 30 June 2012, 22:46 GMT
Urgh, commented on the wrong bug. Could you take a look at what I said in https://awesome.naquadah.org/bugs/index.php?do=details&task_id=973#comment3075 ?
Comment by Anton (zhuravlik) - Sunday, 01 July 2012, 09:28 GMT
Added printf's. Results are attached.

For IDEA: opened xterm, launched IDEA, selected create new project -> import from external model -> maven -> specified options -> next -> hang, killed IDEA, closed xterm
For MATLAB: opened xterm, launched MATLAB, opened several menus and switched focus between different panes, closed MATLAB, closed xterm
Comment by Uli Schlachter (psychon) - Sunday, 01 July 2012, 12:34 GMT
Could you try how much the attached patch fixes and how much it breaks?

This should fix a case where awesome unfocuses a client with the nofocus hint set, but which was given the input focus through some dark magic (globally active input model, I'm looking at you!) anyway.
   patch (1.5 KiB)
Comment by Anton (zhuravlik) - Sunday, 01 July 2012, 13:29 GMT
This patch fixed nothing and broke nothing at all.

Still the same issues with MATLAB and IDEA after applying this patch.
Maybe these apps are poorly written, because with NetBeans, for example, there are and were no problems at all.

Loading...