awesome

Welcome to awesome bug tracking system.
Tasklist

FS#154 - Opera blocking keyboard input

Attached to Project: awesome
Opened by Matti Rudolph (matti) - Thursday, 03 April 2008, 18:55 GMT
Last edited by Julien Danjou (jd) - Thursday, 31 July 2008, 12:20 GMT
Task Type Bug Report
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version 2.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

How to reproduce:
Open a new tab in Opera, browse to a website and switch to an empty tag before the page has loaded.

This will disable all keyboard commands and is only overcome by switching tags via mouse by clicking on the status bar. Maybe other mouse commands work as well.

Opera seems to completely block all communication between awesome and the keyboard.
I don't know if this is actually an Opera bug, what with it maybe issuing some forbidden behavior or something of the sort, but maybe you can circumvent it in awesome.
This task depends upon

Closed by  Julien Danjou (jd)
Thursday, 31 July 2008, 12:20 GMT
Reason for closing:  Fixed
Additional comments about closing:  Seems fixed in HEAD.
Comment by Midare Kiyura (kiyura) - Tuesday, 08 April 2008, 05:22 GMT
I get the same problem with Opera 9.26, awesome 2.2.300.g568117d (git).
Comment by calmar (calmar) - Monday, 21 April 2008, 00:18 GMT
seems to be a similar case this this here: http://awesome.naquadah.org/bugs/index.php?do=details&task_id=75&project=1&status%5B0%5D=open&pagenum=2

(where a java program, after closing it, 'disable's all keyboard commands.
Comment by Midare Kiyura (kiyura) - Thursday, 08 May 2008, 03:52 GMT
I have confirmed the same bug with the development (9.5) version of Opera and awesome-3. It's especially annoying since I don't have any clickable elements like a taglist, I get stuck. It seems to happen only when I close a window. A page doesn't have to be loading. I haven't isolated the cause further than that.
Comment by calmar (calmar) - Saturday, 10 May 2008, 04:12 GMT
about the similar bug on tvbrowser, i git-bisect'ed it to:
485614f2df7f90b8d4a2fe8740c7b2686166b393 is first bad commit

when someone could try to confirm maybe for the opera bug here.
Comment by calmar (calmar) - Sunday, 11 May 2008, 15:27 GMT
I tried to test it with opera too, but not sure about it. Could be at the same commit.

As a workaround, you can open a terminal there, and over the terminal open your opera (floating). like this you won't lose the ability to use your keys.
Comment by Thomas Guebels (tomachaka) - Sunday, 11 May 2008, 18:04 GMT
I used Opera 9.26 and now 9.5 and I never had this bug, from awesome 1.x to 2.3.

Do you want some information about my config ? Maybe it could help...
Comment by Norbert Csibra (birno) - Sunday, 11 May 2008, 20:12 GMT
I have the same problem with Opera 9.50 and awesome 2.3.
Comment by calmar (calmar) - Thursday, 15 May 2008, 22:31 GMT
at parent of 485614f2df7f90b8d4a2fe8740c7b2686166b393 awesome crashes like:

awesome: fatal error: request code=42, error code=8
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 42 (X_SetInputFocus)
Serial number of failed request: 18811
Current serial number in output stream: 18827

waiting for X server to shut down xterm: fatal IO error 32 (Broken pipe) or KillClient on X server ":0.0"
FreeFontPath: FPE "/usr/share/fonts/misc" refcount is 2, should be 1; fixing.
Comment by odd rune s lykkebø (atypic) - Friday, 13 June 2008, 06:30 GMT
Reproducable here too, just a bit more severe -- Opera 9.5 does not accept *any* keyboard input.
Comment by Julien Danjou (jd) - Tuesday, 17 June 2008, 09:49 GMT
Can't reproduce that in current HEAD.

Loading...