awesome

Welcome to awesome bug tracking system.
Tasklist

FS#175 - No clean way to clear a textbox after 2.2

Attached to Project: awesome
Opened by Dag Odenhall (donri) - Wednesday, 23 April 2008, 02:06 GMT
Last edited by Julien Danjou (jd) - Wednesday, 23 April 2008, 06:48 GMT
Task Type Bug Report
Category Widgets
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version git/master
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Sending the text attribute an empty argument with widget_tell seems most intuitive, but has no effect. Sending a widget an empty argument in 2.2 cleared it out. Sending a space works but doesn't feel quite right, more like a hack, makes amazing configuration more complex and probably doesn't work quite as intended with dynamic placement.

Reproduce:

echo 0 widget_tell mystatusbar some_textbox text foo | awesome-client
echo 0 widget_tell mystatusbar some_textbox text | awesome-client

still says "foo"

echo 0 widget_tell mystatusbar some_textbox text ' ' | awesome-client

now it is "cleared" (but not in reality).


2.2:

echo 0 widget_tell some_textbox foo | awesome-client
echo 0 widget_tell some_textbox | awesome-client

... cleared, nice and dandy.
This task depends upon

Closed by  Julien Danjou (jd)
Wednesday, 23 April 2008, 06:48 GMT
Reason for closing:  Fixed
Additional comments about closing:  commit ce17b1457efb056de7068b556c6e92ead441b694
Author: marco candrian <mac@calmar.ws>
Date: Wed Apr 23 05:35:55 2008 +0200

[widgets] allow NULL for 'command' ( FS#175 )

Signed-off-by: Julien Danjou <julien@danjou.info>

Loading...