awesome

Welcome to awesome bug tracking system.
Tasklist

FS#180 - Add vertical re-sizing

Attached to Project: awesome
Opened by Tim Conrad (mortini) - Wednesday, 30 April 2008, 00:27 GMT
Last edited by Julien Danjou (jd) - Monday, 26 January 2009, 15:37 GMT
Task Type Feature Request
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Very Low
Priority Normal
Reported Version git/master
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Adding the ability to vertically re-size a tag, so if you had


| | |
| |___|
| | |
| | |

It could be resized to:

| | |
| | |
| | |
| |___|

Using a minimize/maxmize feature for 0/100% or via the keyboard for incremental differences.
This task depends upon

Closed by  Julien Danjou (jd)
Monday, 26 January 2009, 15:37 GMT
Reason for closing:  Implemented
Additional comments about closing:  commit f2f7d5c89dc4a3fb9504b7a8db0fff4faddd3dca
Author: dcurtis@cs.uiowa.edu <dcurtis@cs.uiowa.edu>
Date: Tue Jan 13 13:31:37 2009 -0600

awful.layout.suit.vile: import

Signed-off-by: Julien Danjou <julien@danjou.info>
Comment by Tim Conrad (mortini) - Wednesday, 30 April 2008, 00:29 GMT
Yeah. That ascii art translated terribly.

But, fwiw, wmii has this capability. Not saying to keep up with that, but a co-worker uses wmii, and it seems really useful.
Comment by Tim Conrad (mortini) - Wednesday, 30 April 2008, 00:33 GMT
Er, looks like dupe of  FS#20 
Comment by Gigamo (Gigamo) - Wednesday, 30 April 2008, 09:27 GMT
A stacking mode could also be nice. Like here on the right: http://arch.har-ikkje.net/gfx/ss/2008-04-28-002258_1680x1050_scrot.png

Only one window is fully shown, all the others are "stacked" with only their titlebars.
Comment by Martin Stubenschrott (maxauthority) - Wednesday, 30 April 2008, 09:48 GMT
Yeah I agree, stacking mode would be really cool, and now that we have titlebars, also feasible. Just no idea, how it would work with them being off.
Comment by Martin Duquesnoy (xorg62) - Saturday, 10 May 2008, 18:27 GMT
it's needed for me too :)
Comment by Anson MacKeracher (amackera) - Monday, 03 November 2008, 21:52 GMT
This would be very nice!

Loading...