awesome

Welcome to awesome bug tracking system.
Tasklist

FS#215 - Awesome cannot start without timer hook

Attached to Project: awesome
Opened by Adam Rooke (Abelian) - Tuesday, 17 June 2008, 20:46 GMT
Last edited by Julien Danjou (jd) - Wednesday, 18 June 2008, 07:58 GMT
Task Type Bug Report
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version git/master
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

With the most recent version of awesome-git it is impossible to start awesome without having the timer hook in awesomerc.lua. No error is posted in the terminal when it doesn't - I can reproduce it with this awesomerc.lua (default with timer hook removed) attatched.
   awesome (12.3 KiB)
This task depends upon

Closed by  Julien Danjou (jd)
Wednesday, 18 June 2008, 07:58 GMT
Reason for closing:  Fixed
Additional comments about closing:  commit 4617f0ba34a49598cc230e8e083719d4e2bd1503
Author: Pierre Habouzit <madcoder@debian.org>
Date: Tue Jun 17 23:13:08 2008 +0200

The X socket MUST keep us alive.

We must not unref the loop for the X socket, that's our reason to live !

Signed-off-by: Pierre Habouzit <madcoder@debian.org>
Comment by Michael Gehring (mg) - Tuesday, 17 June 2008, 21:59 GMT
Indeed without timer in the config file

main.c:
506 ev_loop(globalconf.loop, 0);

just returns, most likely due to a reference count of 0.

Adding a ev_ref(globalconf.loop); before calling ev_loop works, but is probably not the right fix for this.

Loading...