awesome

Welcome to awesome bug tracking system.
Tasklist

FS#253 - building problem with gdk-pixbuf and -DWITH_IMLIB2=1

Attached to Project: awesome
Opened by Dawid Ci??arkiewicz (dpc) - Sunday, 10 August 2008, 13:00 GMT
Last edited by Julien Danjou (jd) - Sunday, 10 August 2008, 14:31 GMT
Task Type Bug Report
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version git/master
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Suspected commit: 533dee543f2b0496ab88da531051c4c9a7252636


In todays git version compilation fails with -DWITH_IMLIB2=1 . The problem is - there are still some function in the code that use gdk-pixbuf, while wth IMLIB2=1 gdk-pixbuf libraries/include paths are no longer proceeded by the CMake if IMLIB2 is not false.

Related:
http://bbs.archlinux.org/viewtopic.php?id=53147
This task depends upon

Closed by  Julien Danjou (jd)
Sunday, 10 August 2008, 14:31 GMT
Reason for closing:  Fixed
Additional comments about closing:  commit a921f605104b7a2ac37302b68faf4e9f92151b36
Author: Michael Gehring <mg@ebfe.org>
Date: Sat Aug 9 05:44:51 2008 +0200

version: fix #include order

Signed-off-by: Julien Danjou <julien@danjou.info>
Comment by Michael Gehring (mg) - Sunday, 10 August 2008, 14:10 GMT
There's a problem with ordering of the includes in version.c, WITH_IMLIB2 is checked before including config.h so its always false. The attached patch might help.

Loading...