awesome

Welcome to awesome bug tracking system.
Tasklist

FS#294 - Config file error since rc2 -> bad argument #-2 to 'widgets' (widget expected, got table)

Attached to Project: awesome
Opened by Stefan Ritter (xeno) - Saturday, 30 August 2008, 18:08 GMT
Last edited by Julien Danjou (jd) - Sunday, 31 August 2008, 06:34 GMT
Task Type Bug Report
Category Core
Status Closed
Assigned To No-one
Operating System Linux
Severity High
Priority Normal
Reported Version 3.0-rc5
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi,

this bug exist since rc2 for me, so i am using rc1. Now i want to use rc5, but the bug is still existing. This is the error after startx and kill it again:

1 E: unable to load theme @AWESOME_THEMES_PATH@/default
2 W: awesome: draw_image_new:788: cannot load image @AWESOME_ICON_PATH@/awesome16.png: Failed to open file '@AWESOME_ICON_PATH@/awesome16.png': No such file or directory
3 W: awesome: draw_image_new:788: cannot load image @AWESOME_ICON_PATH@/layouts/tilew.png: Failed to open file '@AWESOME_ICON_PATH@/layouts/tilew.png': No such file or directory
4 W: awesome: draw_image_new:788: cannot load image @AWESOME_ICON_PATH@/layouts/tilew.png: Failed to open file '@AWESOME_ICON_PATH@/layouts/tilew.png': No such file or directory
5 /home/xeno/.config/awesome/rc.lua:141: bad argument #-2 to 'widgets' (widget expected, got table)
6 /etc/xdg/awesome/rc.lua:85: a tag with the name `1' is already on screen 0
7 mv: Aufruf von stat für ?/home/xeno/.cache/awesome/lastwallpaper.tmp? nicht möglich: Datei oder Verzeichnis nicht gefunden
8 FreeFontPath: FPE "/usr/share/fonts/X11/misc" refcount is 2, should be 1; fixing.

I did the following:
$ make
$ make install
$ cp awesomerc.lua.in ~/.config/awesome/rc.lua
$ startx

Regards, Stefan
This task depends upon

Closed by  Julien Danjou (jd)
Sunday, 31 August 2008, 06:34 GMT
Reason for closing:  Not a bug
Additional comments about closing:  You copied the unconfigured config file (.in) so your configuration file is wrong.

Loading...