awesome

Welcome to awesome bug tracking system.
Tasklist

FS#297 - keybord is very slow sometimes

Attached to Project: awesome
Opened by Michal Nowak (mnowak) - Wednesday, 03 September 2008, 10:51 GMT
Last edited by Julien Danjou (jd) - Monday, 08 December 2008, 13:36 GMT
Task Type Bug Report
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity High
Priority Normal
Reported Version git/master
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

First, let me say that I don't have much information to share with you, but I at least seek for someone with the same problem.

I am using awesome-3 on Fedora 9 (https://bugzilla.redhat.com/show_bug.cgi?id=452427) sometimes it happen that the key events are lost.

1) login via GDM (xdesktop file)

2) run these apps:
urxvtd &
pulseaudio -D
gnome-power-manager
gnome-screensaver
nm-applet &
kerneloops-applet &
gpk-update-icon &
system-config-printer-applet &
sealert &

+ firefox, evolution.

3) do some work in awesome

4) after some time (hours, days, ...) it happens that pressing some key in does nothing. I realized that when I hold the key for ~1 sec or so, the key is finally generated.

The only solution to get back to normal behavior was to quit awesome and start new session. Mouse is OK all the time.

I have opened Xorg.0.log and dmesg via tailf, but nothing emerged there when the fault happened.

I am not blaming awesome, but weird is that it never happened in GNOME.

Does anyone ever seen some strange behavior?
This task depends upon

Closed by  Julien Danjou (jd)
Monday, 08 December 2008, 13:36 GMT
Reason for closing:  Works for me
Additional comments about closing:  Not related to awesome directly, no update since more than one month.
Comment by kipper (boyinasuitcase) - Friday, 05 September 2008, 22:11 GMT
I can confirm. I experience basically the same thing running 2.3.4 Every once and a while after the system has been running for a while, pressing the key does nothing. Mouse works and sometimes if I wait long enough the functionality comes back. nothing in logs to indicate that the key event was missed or even seen.
Comment by Julien Danjou (jd) - Sunday, 07 September 2008, 21:36 GMT
That really miss proof. Are you both running Fedora?
Comment by Michal Nowak (mnowak) - Saturday, 13 September 2008, 09:29 GMT
The workaround for this is to run gnome-keyboard-properties and speedup (or slowdown, or both) the "Repeat Keys" -> "Delay". Some other X-only tools should do the same trick. Still, never seen it outside of awesome.
Comment by Michal Nowak (mnowak) - Wednesday, 17 September 2008, 08:08 GMT
Well, the thing is that gnome-keyboard-properties starts some GNOME-related stuff, *which*, I guess, doe the magic stuff and "speeds up" the key pressing. I thing because no +/- on key press delay is necessary.

Anyone can confirm?
Comment by ganriel pettier (tshirtman) - Friday, 19 September 2008, 20:40 GMT
I can confirm slowness and repeated keys on debian on eeepc701, this is sad because I expected a really the system to be smooth even on a 701.

I just start a few gnome-terminals, pidgin, nm-applet and firefox3 (~10 non flash tabs), and it can appear... (well not all time it's currently pretty ok, I don't know what was the cause).
Comment by Michal Nowak (mnowak) - Saturday, 20 September 2008, 14:21 GMT
ganriel pettier (tshirtman): It's not a HW fault, SW problem is here more likely. Try to run gnome-keyboard-properties on your system, if present, and see whether it helps.
Comment by Michal Nowak (mnowak) - Sunday, 05 October 2008, 20:21 GMT
I am idiot, this is not the right bug. Do not close.
Comment by OttoAllmendinger (OttoA) - Wednesday, 22 October 2008, 07:46 GMT
I have just noticed the same thing. The top command shows me that the Xorg process CPU load spikes to 20% or 30% every 5 seconds or so. I guess that might have something to do with it.

When I kill xcompmgr it only spikes to 8%, but that is still too much in my opinion.
Comment by Michal Nowak (mnowak) - Thursday, 23 October 2008, 07:12 GMT
Otto:

What distro is it?

I am on Fedora Rawhide and don't have xcompmgr, but will definitely check whether is there the 20-30% spinning.
Comment by OttoAllmendinger (OttoA) - Thursday, 23 October 2008, 12:03 GMT
I am using ArchLinux and the files from the repository suggested in the wiki.

On second reading, I think our bugs are not related.

I once had the same bug as you, but I think it was with KDE and Compiz, not with awesome. All I could do was hit Ctrl-Alt-Backspace (slowly and sequentially ;-))

Loading...