awesome

Welcome to awesome bug tracking system.
Tasklist

FS#306 - Cmake won't find lua50

Attached to Project: awesome
Opened by Timo Myyrä (zmyrgel) - Sunday, 07 September 2008, 10:39 GMT
Last edited by Julien Danjou (jd) - Sunday, 07 September 2008, 14:30 GMT
Task Type Bug Report
Category Build system
Status Closed
Assigned To No-one
Operating System Linux
Severity Medium
Priority Normal
Reported Version 3.0-rc6
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The cmake fails to find lua50 although it is installed to system. Currently running fifth alpha release of Ubuntu 8.10.

zmyrgel@desky:~/src/awesome-3.0-rc6$ make
Running cmake…
-- cat -> /bin/cat
-- ln -> /bin/ln
-- grep -> /bin/grep
-- git -> /usr/bin/git
-- hostname -> /bin/hostname
-- gperf -> /usr/bin/gperf
-- luac5.1 -> /usr/bin/luac5.1
-- luac-5.1 -> /usr/bin/luac5.1
-- luac -> /usr/bin/luac5.1
-- asciidoc -> /usr/bin/asciidoc
-- xmlto -> /usr/bin/xmlto
-- gzip -> /bin/gzip
-- lua -> /usr/bin/lua
-- luadoc -> /usr/bin/luadoc
-- Looking for doxygen...
-- Looking for doxygen... - found /usr/bin/doxygen
-- Looking for dot tool...
-- Looking for dot tool... - found /usr/bin/dot
-- Could NOT find Lua50
-- Configuring config.h
-- Configuring awesomerc.lua
-- Configuring themes/default
-- Configuring lib/awful.lua
-- Configuring lib/beautiful.lua
-- Configuring lib/tabulous.lua
-- Configuring awesome-version-internal.h
-- Configuring awesome.doxygen
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
LUA_INCLUDE_DIR (ADVANCED)
used as include directory in directory /home/zmyrgel/src/awesome-3.0-rc6
-- Configuring done
make: *** [cmake] Error 1
zmyrgel@desky:~/src/awesome-3.0-rc6$ ls -l /usr/bin/lua*
lrwxrwxrwx 1 root root 33 2008-09-07 10:02 /usr/bin/lua -> /etc/alternatives/lua-interpreter
-rwxr-xr-x 1 root root 11968 2007-10-24 12:14 /usr/bin/lua50
-rwxr-xr-x 1 root root 141608 2008-05-11 16:44 /usr/bin/lua5.1
lrwxrwxrwx 1 root root 30 2008-09-07 10:02 /usr/bin/luac -> /etc/alternatives/lua-compiler
-rwxr-xr-x 1 root root 9904 2007-10-24 12:14 /usr/bin/luac50
-rwxr-xr-x 1 root root 89660 2008-05-11 16:44 /usr/bin/luac5.1
lrwxrwxrwx 1 root root 35 2008-09-07 10:30 /usr/bin/lua-config -> /etc/alternatives/lua-configuration
-rwxr-xr-x 1 root root 3657 2007-10-24 12:14 /usr/bin/lua-config50
-rwxr-xr-x 1 root root 3236 2008-05-11 13:57 /usr/bin/luadoc
zmyrgel@desky:~/src/awesome-3.0-rc6$

This task depends upon

Closed by  Julien Danjou (jd)
Sunday, 07 September 2008, 14:30 GMT
Reason for closing:  Not a bug
Additional comments about closing:  It needs lua5.1; cmake prints lua50 but it's a bug in cmake.

Loading...