awesome

Welcome to awesome bug tracking system.
Tasklist

FS#328 - Focus is on the wrong window when switching back to a tag that has a shared window

Attached to Project: awesome
Opened by Andrei Thorp (garoth) - Friday, 26 September 2008, 20:41 GMT
Last edited by Uli Schlachter (psychon) - Sunday, 15 August 2010, 17:09 GMT
Task Type Feature Request
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Very Low
Priority Normal
Reported Version git/master
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Best way to explain this is with the steps to replicate:

- Open two terminals in two tags, one per tag
- Go to the second tag, select your terminal there, and activate awful.client.toggletag on it (default mod+control+shift+number) to have it in your other tag also
* in the first tag, you should now have both terminals visible
- In tag 1, select the first terminal that was there (the one you originally spawned in it)
- Switch to tag 2
- Switch back to tag 1, and notice that now the _other_ terminal (the one from tag 2) is now the active one.

The default (and expected) behaviour for awesome is to remember which client you had focussed on a tag, and go back to that one when you switch away and come back. But when you have a client shared on multiple tags, it will claim focus IF it is the one you had focussed on the other tag that you were just in.

Sorry, I know it's kind of complicated to wrap your mind around. Cheers.

Oh, and: $(git describe) = "v3.0-108-g5709435" (latest from awesome origin/master)
This task depends upon

Closed by  Uli Schlachter (psychon)
Sunday, 15 August 2010, 17:09 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Same bug was FS#574, even though the title there doesn't describe this bug.
Comment by Julien Danjou (jd) - Saturday, 27 September 2008, 06:50 GMT
Yes, because the focus history in awful take the latest focused window visible on that tag. Since the window is on the 2 tags, it will match as the latest focused one.
I keep that open in case someone wants to furnish a patch against awful.
Comment by Uli Schlachter (psychon) - Friday, 11 December 2009, 19:10 GMT
I seem to be too stupid for reproducing this. Does this still happen with the "new" tag history?
Comment by Uli Schlachter (psychon) - Sunday, 14 March 2010, 14:11 GMT
If I remember correctly, the focus history code only kicks in if no client has the focus. That might also explain  FS#736 .

Loading...