awesome

Welcome to awesome bug tracking system.
Tasklist

FS#394 - Windows-focus-foo not working properly

Attached to Project: awesome
Opened by sebastian bach (sbi-) - Saturday, 29 November 2008, 16:44 GMT
Last edited by Julien Danjou (jd) - Monday, 08 December 2008, 13:33 GMT
Task Type Bug Report
Category Core
Status Closed
Assigned To No-one
Operating System Linux
Severity High
Priority Normal
Reported Version git/master
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

I just updated to awesome 3.1-rc4 (tried git/master from Sat Nov 29 17:39:59 CET 2008 too) and (even with the default config shipped with awesome) have the following problem:

- the currently focused window is not highlighted in the taskbar
- switching windows-focus by moving the mouse over different windows or using mod+{j,k} does not work
- when switching tags, the taskbar is not updated until a window on the now active tag changes its title or is created/destroyed.

I'm using debian lenny/sid on ppc, and the xcb-util 0.3.1-2 package from experimental.

There are no errors printed on std{out,err}.

I'll be happy to answer any further questions or assist in debugging anyway I can with my very limited C/X11 skills.
This task depends upon

Closed by  Julien Danjou (jd)
Monday, 08 December 2008, 13:33 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Bug in xcb-util <= 0.3.1.
Comment by Julien Danjou (jd) - Saturday, 29 November 2008, 17:03 GMT
You really have no way to change focus ?
Comment by sebastian bach (sbi-) - Saturday, 29 November 2008, 17:25 GMT
when I *click* on another window, I can change the focus (allthough the border color does not change accordingly)
Comment by sebastian bach (sbi-) - Saturday, 29 November 2008, 17:35 GMT
I just downgraded to awesome 3.0, keeping the new xcb-util version and the problem is gone, so it's not that. (Don't know if that was even a possibility..)
Comment by Julien Danjou (jd) - Saturday, 29 November 2008, 17:36 GMT
Try in awesome-client:

client.focus = awful.client.visible()[1]
client.focus = awful.client.visible()[2]
etc..
to see if the focus switch.

return client.focus.name
should return you the name of the focused window (according to awesome)>
Comment by Julien Danjou (jd) - Saturday, 29 November 2008, 17:37 GMT
Ok, so I think the easiest way to debug this one would be a git bisect.
Comment by sebastian bach (sbi-) - Saturday, 29 November 2008, 17:49 GMT
ok, so switching the focus by moving the mouse does work after all, it was just the missing visual indicator because of the missing border-color and taskbar changes that through me off
Comment by sebastian bach (sbi-) - Saturday, 29 November 2008, 17:50 GMT
I was fearing it would come to that (bisect). The problem is that I need >30min to build/install a single version of awesome on this oldish ibook. So it may take me quite a while. I will get on it though.
Comment by Maarten Maathuis (madman2003) - Sunday, 30 November 2008, 13:39 GMT
IIRC your rc.lua didn't have the border color changing hooks, please check that before you go off on a wild goose chase. Or even better, try the default config.
Comment by Julien Danjou (jd) - Sunday, 30 November 2008, 18:12 GMT
This has been tracked down with a bisect to being a problem in xcb-util filling the structure of wmhints.
Comment by sebastian bach (sbi-) - Wednesday, 03 December 2008, 19:03 GMT
If you read my bug report carefully, you will find out that I did try the default config. :-)
Comment by Julien Danjou (jd) - Monday, 08 December 2008, 13:32 GMT
We found the bug. It was a miswritten protocol structure in xcb-util. You can check out the git repository of xcb-util to get the bug fixed or wait for a new xcb-util release.

Loading...