awesome

Welcome to awesome bug tracking system.
Tasklist

FS#41 - Problem with apps embeded in Firefox

Attached to Project: awesome
Opened by Julien Danjou (jd) - Sunday, 20 January 2008, 15:44 GMT
Last edited by Julien Danjou (jd) - Sunday, 07 September 2008, 21:44 GMT
Task Type Bug Report
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Medium
Priority Normal
Reported Version git/master
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

When opening for example a PDF in firefox with mozplugged, xpdf window is run inside Firefox but awesome thinks there's 2 windows.

No idea why.
This task depends upon

Closed by  Julien Danjou (jd)
Sunday, 07 September 2008, 21:44 GMT
Reason for closing:  Duplicate
Additional comments about closing:  commit 4089e8eca85e0388632b7e6a30afd377ce6d4d57
Author: Julien Danjou <julien@danjou.info>
Date: Sun Sep 7 23:43:40 2008 +0200

event: unmanage or external reparenting ( FS#41 )< br />
Signed-off-by: Julien Danjou <julien@danjou.info>
Comment by Michal Nowak (newman) - Sunday, 20 January 2008, 19:21 GMT
I am facing it too. The other problem is the usage of mouse in that swallowed app (i.e. in OpenOffice.org's Writer I am not able to click on anything, same in evince), even in mozplugger-1.10.1 (latest).

I can see this problem in awesome only.
Comment by Michal Nowak (newman) - Sunday, 20 January 2008, 19:23 GMT
But all keyboard keys work.
Comment by Jérémie Delaitre (viridis) - Wednesday, 23 January 2008, 17:51 GMT
I've the same problem with the BitTorrent client : Deluge
But the keyboard does not work too here !

Indeed the problem is quite strange.
When I launch Deluge in background from a terminal I have the problem.
But when I launch it from a terminal in foreground, I've no problem at all. In this case, a popup window is displayed (for a new version of deluge blablabla) but this popup is not displayed when deluge is launched in background directely (with: $ deluge&).
Comment by hinnerk (hinnerk) - Monday, 07 April 2008, 09:34 GMT
same problem here with twitterfox addon for firefox
Comment by calmar (calmar) - Friday, 25 April 2008, 19:18 GMT
i got that on 'flash' thingies out of firefox (via 'xprop'):
_XEMBED_INFO(_XEMBED_INFO) = 0xbff97868, 0x0

maybe based on such things, they could be handled then.
Comment by Julien Danjou (jd) - Wednesday, 30 April 2008, 09:27 GMT
Well I still do not really know how to detect xembeded window, it seems that there's something with reparenting.
Comment by calmar (calmar) - Monday, 25 August 2008, 16:31 GMT
I don't have anymore those 'second' clients, btw. git version awesome (awesome) v3.0-rc4 (Scared Of Girls) ;)

Loading...