awesome

Welcome to awesome bug tracking system.
Tasklist

FS#411 - Setting mwfact error in awesome-git

Attached to Project: awesome
Opened by Dmitrij (DsTr) - Wednesday, 24 December 2008, 15:25 GMT
Last edited by Gregor Best (farhaven) - Wednesday, 24 December 2008, 15:59 GMT
Task Type Bug Report
Category Lua libraries → awful
Status Closed
Assigned To No-one
Operating System Linux
Severity High
Priority Normal
Reported Version git/master
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When i use setmwfact function, or tag({ name = "im", mwfact = 0.125}), or require('eminent'), awesome says:

".. bad argument #2 to 'tag' (string expected, got table)"
This task depends upon

Closed by  Gregor Best (farhaven)
Wednesday, 24 December 2008, 15:59 GMT
Reason for closing:  Not a bug
Additional comments about closing:  That's the new syntax
Comment by Gregor Best (farhaven) - Wednesday, 24 December 2008, 15:59 GMT
That is not a bug. In the git version, tag() only accepts one argument, which would be the name of the tag. All other tag related variables are stored using awful functions. For setting the tags mwfact, you'd use awful.tag.setmwfact(mwfact, tag). If you omit the tag argument, the first selected tag is used.

Loading...