awesome

Welcome to awesome bug tracking system.
Tasklist

FS#433 - Crash on issuing awesome.restart

Attached to Project: awesome
Opened by Seynthan Thanapalan (Stxza) - Sunday, 18 January 2009, 19:34 GMT
Last edited by Julien Danjou (jd) - Monday, 09 February 2009, 10:49 GMT
Task Type Bug Report
Category Core
Status Closed
Assigned To No-one
Operating System Linux
Severity Critical
Priority Normal
Reported Version git/master
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Version 3.1-194-gd6655d7 built with gcc version 4.3.2
OS: Arch Linux x86_64

Basically I start awesome and open clients if I want or not then issue the mod4+ctrl+r bindings for restart:

1)table.insert(globalkeys, key({ modkey, "Control" } , "r" , function () promptbox[mouse.screen].text = awful.util.escape(awful.util.restart()) end))
OR
2) table.insert(globalkeys, key({ modkey, "Control" } , "r" , awesome.restart))
Have same effect.

Firstly the statusbar/wibox disappears then I see I cant issue any more bindings and what not so I assume a full crash, I can only see the wallpaper. I can't find any errors reported in my log file either. I've asked around on #awesome and others don't have this. The interesting thing is that exactly same thing happens with the default config. Other than this problem I can use awesome as normal and the awesome.quit function works as normal.

My Configs:
rc.lua and functions.lua from http://github.com/stxza/arch-linux-configs/tree/master/.config%2Fawesome
This task depends upon

Closed by  Julien Danjou (jd)
Monday, 09 February 2009, 10:49 GMT
Reason for closing:  Not a bug
Comment by Julien Danjou (jd) - Monday, 19 January 2009, 08:51 GMT
That probably means it cant reload the configuration file.
Do you have specified a different configuration file with the -c option or something like that ?
Comment by Seynthan Thanapalan (Stxza) - Monday, 19 January 2009, 09:01 GMT
Okay, do you want me to try another config? The same thing happens when I copy the default config into $HOME/.config/awesome/rc.lua
So for both my config and default config I can start Awesome fine initially but afterwards when I try to restart the crash happens (without modifying anything in the config)
Comment by Seynthan Thanapalan (Stxza) - Monday, 19 January 2009, 09:03 GMT
Im currently not using the -c option when starting awesome but like this:

#!/bin/sh
#
# ~/.xinitrc
# Executed by startx (run your window manager from here)
xrdb -merge $HOME/.Xresources &
xmodmap $HOME/.Xmodmap &
xbindkeys &
#xsetroot -bg black -cursor_name left_ptr &
nvidia-settings --load-config-only &
urxvtd -q -o -f &
# parcellite &
# D-bus
if which dbus-launch >/dev/null && test -z "$DBUS_SESSION_BUS_ADDRESS"; then
eval `dbus-launch --sh-syntax --exit-with-session`
fi
exec awesome > $HOME/.awesome.log 2>&1
Comment by Julien Danjou (jd) - Monday, 19 January 2009, 11:51 GMT
« crash happen ». Does that mean awesome is not running anymore ?
Comment by Seynthan Thanapalan (Stxza) - Monday, 19 January 2009, 12:02 GMT
Okay I just checked that from another console after the status bar disappears and awesome appears to be frozen - but it's actually still running and taking much less memory (1.7Mb vs normally 16Mb) and of course I can't recover it from there and have to kill X.
Comment by Seynthan Thanapalan (Stxza) - Monday, 19 January 2009, 21:06 GMT
Just confirming that this also happens on my desktop, I pretty much copied a bunch of system config files and also awesome configs over to the desktop and get the same problem when doing a Awesome restart.
Comment by Seynthan Thanapalan (Stxza) - Monday, 19 January 2009, 21:06 GMT
Desktop is using v3.1-198-g3aa407b
Comment by Seynthan Thanapalan (Stxza) - Monday, 19 January 2009, 21:33 GMT Comment by Nikos Ntarmos (ntarmos) - Monday, 26 January 2009, 00:28 GMT
If the process is still running, could you please try to build a debug (-g) awesome executable, attach gdb to the running process (i.e. 'gdb ./awesome xxx', where xxx is the pid of the awesome process) and give us the output of 'bt'? That would give us an idea of where the problem might be...

Loading...