awesome

Welcome to awesome bug tracking system.
Tasklist

FS#460 - Aplications with systray crashes when systray is disabled

Attached to Project: awesome
Opened by Ulises Arias (uarias) - Monday, 23 February 2009, 02:27 GMT
Last edited by Julien Danjou (jd) - Monday, 23 February 2009, 09:10 GMT
Task Type Bug Report
Category Wibox
Status Closed
Assigned To No-one
Operating System Linux
Severity Medium
Priority Normal
Reported Version git/master
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hello,

When an application uses the systray it works normally until the systray is disabled in the mentioned application.
with other window managers such as fluxbox, kwin, openbox and gnome this do not happens.

This was tested with x86 and x86_64.

awesome
(awesome) v3.2-rc3 (Chocolate)
• Build: Feb 22 2009 16:02:50 for x86_64 by gcc version 4.3.3 (ulises@dante)
• D-Bus support: ?




The tested applications:

audacious:

----Trace Audacious----

This GDB was configured as "x86_64-linux-gnu"...
(gdb) run
Starting program: /usr/bin/audacious
[Thread debugging using libthread_db enabled]
[New Thread 0x7fb4f99d4740 (LWP 20058)]
[New Thread 0x7fb4f8eec950 (LWP 20062)]
amidi-plug(amidi-plug.c:amidiplug_init:97): init, read configuration
amidi-plug(i_backend.c:i_backend_load:107): loading backend '/usr/lib/audacious/
Input/amidi-plug/ap-alsa.so'
amidi-plug(i_backend.c:i_backend_load:145): backend /usr/lib/audacious/Input/ami
di-plug/ap-alsa.so (name 'alsa') successfully loaded
/home/ulises/.themes/Dust Cold/gtk-2.0/gtkrc:709: error: unexpected identifier `
highlight_ratio', expected character `}'
[New Thread 0x7fb4eebac950 (LWP 20069)]
[New Thread 0x7fb4edda6950 (LWP 20071)]
/home/ulises/.themes/Dust Cold/gtk-2.0/gtkrc:709: error: unexpected identifier `
highlight_ratio', expected character `}'

(audacious:20058): GLib-GObject-WARNING **: invalid unclassed pointer in cast to
`GtkWidget'

(audacious:20058): Gdk-CRITICAL **: gdk_x11_display_get_xdisplay: assertion `GDK
_IS_DISPLAY (display)' failed

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fb4f99d4740 (LWP 20058)]
0x000000300322c028 in XGetWindowProperty () from /usr/lib/libX11.so.6
(gdb) run
The program being debugged has been started already.
Start it from the beginning? (y or n) y
Starting program: /usr/bin/audacious
[Thread debugging using libthread_db enabled]
[New Thread 0x7f8dce700740 (LWP 20369)]
[New Thread 0x7f8dcdc18950 (LWP 20370)]
amidi-plug(amidi-plug.c:amidiplug_init:97): init, read configuration
amidi-plug(i_backend.c:i_backend_load:107): loading backend '/usr/lib/audacious/Input/amidi-plug/ap-alsa.so'
amidi-plug(i_backend.c:i_backend_load:145): backend /usr/lib/audacious/Input/amidi-plug/ap-alsa.so (name 'alsa') successfully loaded
/home/ulises/.themes/Dust Cold/gtk-2.0/gtkrc:709: error: unexpected identifier `highlight_ratio', expected character `}'
[New Thread 0x7f8dc38d8950 (LWP 20374)]
[New Thread 0x7f8dc2ad2950 (LWP 20375)]
/home/ulises/.themes/Dust Cold/gtk-2.0/gtkrc:709: error: unexpected identifier `highlight_ratio', expected character `}'

(audacious:20369): GLib-GObject-WARNING **: invalid unclassed pointer in cast to `GtkWidget'

(audacious:20369): Gdk-CRITICAL **: gdk_x11_display_get_xdisplay: assertion `GDK_IS_DISPLAY (display)' failed

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7f8dce700740 (LWP 20369)]
0x000000300322c028 in XGetWindowProperty () from /usr/lib/libX11.so.6



Icedove with traybiff extension (debian)
----- Trace icedove with status-icon extension (traybiff)-----

(gdb) run
Starting program: /usr/lib/icedove/icedove-bin icedove-bin
[Thread debugging using libthread_db enabled]
[New Thread 0x7fe1eedc5700 (LWP 19106)]
[New Thread 0x7fe1ec6ff950 (LWP 19114)]
/home/ulises/.themes/Dust Cold/gtk-2.0/gtkrc:709: error: unexpected identifier `highlight_ratio', expecte
[New Thread 0x7fe1ea9a5950 (LWP 19115)]
[New Thread 0x7fe1e96d0950 (LWP 19116)]
[New Thread 0x7fe1e8ecf950 (LWP 19117)]
[Thread 0x7fe1e8ecf950 (LWP 19117) exited]
[New Thread 0x7fe1e86ce950 (LWP 19118)]
[Thread 0x7fe1e86ce950 (LWP 19118) exited]
[New Thread 0x7fe1e86ce950 (LWP 19122)]
[New Thread 0x7fe1e8ecf950 (LWP 19124)]
[New Thread 0x7fe1e5c6c950 (LWP 19125)]
[New Thread 0x7fe1df055950 (LWP 19131)]
[New Thread 0x7fe1de854950 (LWP 19132)]
[New Thread 0x7fe1dd73d950 (LWP 19134)]
[New Thread 0x7fe1dbb99950 (LWP 19176)]
[New Thread 0x7fe1db317950 (LWP 19189)]
[New Thread 0x7fe1dab16950 (LWP 19213)]
[Thread 0x7fe1dab16950 (LWP 19213) exited]
[Thread 0x7fe1e8ecf950 (LWP 19124) exited]
[Thread 0x7fe1e5c6c950 (LWP 19125) exited]
[Thread 0x7fe1e86ce950 (LWP 19122) exited]
[Thread 0x7fe1dd73d950 (LWP 19134) exited]
[New Thread 0x7fe1dd73d950 (LWP 19289)]
[Thread 0x7fe1db317950 (LWP 19189) exited]
*** Gnome Registry Session: no.
[New Thread 0x7fe1db317950 (LWP 19315)]
[Thread 0x7fe1dd73d950 (LWP 19289) exited]
[New Thread 0x7fe1dd73d950 (LWP 19526)]
[New Thread 0x7fe1e86ce950 (LWP 19527)]
[Thread 0x7fe1e86ce950 (LWP 19527) exited]
[Thread 0x7fe1dd73d950 (LWP 19526) exited]
[New Thread 0x7fe1dd73d950 (LWP 19812)]
[Thread 0x7fe1dd73d950 (LWP 19812) exited]
[New Thread 0x7fe1dd73d950 (LWP 19886)]
[New Thread 0x7fe1e86ce950 (LWP 19949)]

(gecko:19106): GLib-GObject-WARNING **: invalid unclassed pointer in cast to `GtkWidget'

(gecko:19106): Gtk-CRITICAL **: gtk_widget_get_display: assertion `GTK_IS_WIDGET (widget)' failed

(gecko:19106): Gdk-CRITICAL **: gdk_x11_display_get_xdisplay: assertion `GDK_IS_DISPLAY (display)' failed

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fe1eedc5700 (LWP 19106)]
0x000000300322c028 in XGetWindowProperty () from /usr/lib/libX11.so.6


Liferea

------- Liferea trace----
TRACE: + feed_parse
TRACE: - feed_parse
TRACE: + node_get_itemset
TRACE: - node_get_itemset
TRACE: + itemlist_merge_itemset
TRACE: - feed_process_update_result
TRACE: + feed_process_update_result
TRACE: + feed_parse
TRACE: - feed_parse
TRACE: + node_get_itemset
TRACE: - node_get_itemset
TRACE: + itemlist_merge_itemset
TRACE: - feed_process_update_result
TRACE: + default_source_source_export
TRACE: + export_OPML_feedlist
TRACE: + vfolder_export
TRACE: - vfolder_export
TRACE: + vfolder_export
TRACE: - vfolder_export
TRACE: - export_OPML_feedlist
TRACE: - default_source_source_export
TRACE: + feed_process_update_result
TRACE: + feed_parse
TRACE: - feed_parse
TRACE: + node_get_itemset
TRACE: - node_get_itemset
TRACE: + itemlist_merge_itemset
TRACE: - feed_process_update_result
TRACE: + feedlist_auto_update
TRACE: - feedlist_auto_update

(liferea:20164): GLib-GObject-WARNING **: invalid unclassed pointer in cast to `GtkWidget'

(liferea:20164): Gtk-CRITICAL **: gtk_widget_get_display: assertion `GTK_IS_WIDGET (widget)' failed

(liferea:20164): Gdk-CRITICAL **: gdk_x11_display_get_xdisplay: assertion `GDK_IS_DISPLAY (display)' fail
ed

Liferea did receive signal 11 (Violación de segmento).
You have propably triggered a program bug. I will now try to
create a backtrace which you can attach to any support requests.

#0 0x000000300129e4df in waitpid () from /lib/libc.so.6
#1 0x0000003004217547 in g_on_error_stack_trace ()
#2 0x000000000043192a in fatal_signal_handler (sig=11) at main.c:111
#3 <signal handler called>
#4 0x000000300322c028 in XGetWindowProperty () from /usr/lib/libX11.so.6
#5 0x00000000004522a0 in egg_tray_icon_get_orientation_property (
#6 0x0000000000452571 in egg_tray_icon_manager_filter (xevent=0x7fff3cf36190,
#7 0x000000300ac4a0fa in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#8 0x000000300ac4bbe7 in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#9 0x000000300ac4bfbe in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#10 0x0000003004239afb in g_main_context_dispatch ()
#11 0x000000300423d2bd in ?? () from /usr/lib/libglib-2.0.so.0
#12 0x000000300423d7ed in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#13 0x000000300b14f807 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#14 0x0000000000431203 in main (argc=2, argv=0x7fff3cf36598) at main.c:293



This task depends upon

Closed by  Julien Danjou (jd)
Monday, 23 February 2009, 09:10 GMT
Reason for closing:  Not a bug
Additional comments about closing:  This is a bug in the applications using eggtray. This has to be fixed in each application code. Please contact the upstream author to fix it. Patch already exist.

Loading...