awesome

Welcome to awesome bug tracking system.
Tasklist

FS#526 - awesome-3.3 won't launch kde4 apps

Attached to Project: awesome
Opened by Alex Alexander (wired) - Friday, 29 May 2009, 10:30 GMT
Last edited by Julien Danjou (jd) - Thursday, 20 August 2009, 08:50 GMT
Task Type Bug Report
Category Core
Status Closed
Assigned To No-one
Operating System Linux
Severity High
Priority Normal
Reported Version 3.3-rc4
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Im having issues with >=3.3_rc3 when running kde4 apps.

If I try to start any kde4 app with a keyboard shortcut OR with awesome's run prompt, the app never starts.
Kmail does nothing (crashes on start?) while dolphin starts in the background but never shows a window.

Running the apps from an x terminal (urxvt) works OK.
Other apps (gtk, qt4 non-kde4, anything else) start fine.

This happens with 3.3_rc{3,4} and current git master with both my custom rc.lua and the default config.

The issue wasn't there in 3.2 (haven't tested previous 3.3 RCs).
This task depends upon

Closed by  Julien Danjou (jd)
Thursday, 20 August 2009, 08:50 GMT
Reason for closing:  Not a bug
Comment by Nikos Ntarmos (ntarmos) - Friday, 29 May 2009, 11:04 GMT
Probably an environment thing. Do you use spawn or spawn_with_shell to launch those programs?
Comment by Alex Alexander (wired) - Saturday, 30 May 2009, 17:50 GMT
spawn, spawn_with_shell and the run prompt have the same results.

some kde4 apps don't start at all (like kmail), others start and stay in the background (they show up in ps ax) but never draw any windows (like dolphin).
Comment by Julien Danjou (jd) - Sunday, 31 May 2009, 09:01 GMT
Can you see something on stderr or .xsession-errors?
Comment by Alex Alexander (wired) - Sunday, 31 May 2009, 12:28 GMT
unfortunately no, no error output whatsoever...
Comment by Christof Schulze (Klaus_Dieter) - Monday, 15 June 2009, 14:04 GMT
I have the same problem but here it seems to be caused by dbus being messed up. Try if running your application using dbus-launch works.
Comment by Nesta Campbell (canen) - Saturday, 11 July 2009, 16:58 GMT
I confirm that this happening as well (kopete and choqok). Apps do start but stay in the background. I have to maximise them for the window to show, they are set to float by default. I copied the following from the Openbox autostart file and placed it in .xinitrc but I am not sure if it changed anything:

# D-bus
if which dbus-launch >/dev/null && test -z "$DBUS_SESSION_BUS_ADDRESS"; then
eval `dbus-launch --sh-syntax --exit-with-session`
fi

# Preload stuff for KDE apps
if which start_kdeinit >/dev/null; then
LD_BIND_NOW=true start_kdeinit --new-startup +kcminit_startup &
fi

Loading...