awesome

Welcome to awesome bug tracking system.
Tasklist

FS#564 - Awesome and KDE 4.3 systray

Attached to Project: awesome
Opened by Lars Hansson (Soulbender) - Wednesday, 29 July 2009, 12:15 GMT
Last edited by Uli Schlachter (psychon) - Friday, 30 July 2010, 14:36 GMT
Task Type Bug Report
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version 3.3.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

The Awesome systray does not show the icons for some KDE4 apps (kgpg, korganizer, kmix and a few more) in KDE 4.3. The KDE4 bug report is here (http://bugs.kde.org/show_bug.cgi?id=201765) but it seems that it's something with Awesome's systray since it works with XFCE.
Awesome is 3.3.2 from Ubuntu PPA repos.
This task depends upon

Closed by  Uli Schlachter (psychon)
Friday, 30 July 2010, 14:36 GMT
Reason for closing:  Works for me
Additional comments about closing:  kmix shows up in systray without any problems. What am I doing differently than everyone else?
Comment by Florian Friesdorf (chaoflow) - Thursday, 06 August 2009, 21:40 GMT
I have the same problem with korganizer from kde 4.3.0 and awesome v3.3-176-g6ca1732 (Stellar). The others I did not test. Klipper is showing up in the systray.
Comment by Thomas Koch (thkoch2001) - Thursday, 13 August 2009, 08:06 GMT
It seems, that I could fix this issue here by deleting a lot of junk from the .kde folder. Basically everything despite of mails, bookmarks and keybindings.
Still right now the konversation icon seems to have disappeared, when I switched from two displays to one...
Comment by Florian Friesdorf (chaoflow) - Tuesday, 18 August 2009, 15:49 GMT
For me, klipper still shows up in the awesome systray, kmix and korganizer don't. However, kmix and korganizer show up in the kde systray desktop widget, but klipper does not.
Comment by Julien Danjou (jd) - Thursday, 20 August 2009, 08:51 GMT
klipper and kmix 4.3.0 both shows up here.
Comment by Florian Friesdorf (chaoflow) - Wednesday, 26 August 2009, 15:43 GMT
@Julien: which version of awesome are you using?

here: awesome 3.3.3, kde 4.3.0

klipper is still the only one showing up in awesome systray. When I run a kde systray, too, it consumes all systray apps (also klipper) and awesome's systray is empty. When I close the kde systray, klipper moves to awesome's systary but korgac and kmix don't.
Comment by Florian Friesdorf (chaoflow) - Wednesday, 26 August 2009, 15:56 GMT
Any suggestions on how to debug this? I am happy to help, but rather clueless how to start.
Comment by Julien Danjou (jd) - Thursday, 27 August 2009, 08:51 GMT
Hum, awesome systray implementation is not really proof to other systray launch etc. I suggest not to mess up with that.

I've tested with git master, but there's no change between 3.3 and master about the systray code. So it should work the same.

And I've kde 4.3.0 too.
Comment by Florian Friesdorf (chaoflow) - Saturday, 24 October 2009, 01:54 GMT
I meanwhile disabled plasma completely, there is definitely no other systray running. klipper and nm-applet are displayed in awesome's systray.

However: korgac, kmix and kwalletmanager are not.

@Julien: How many applets are displayed for you, more than two? Could you try with korgac, nm-applet and kwalletmanager?

kde 4.3.2
awesome 3.4

How can I debug this?
Comment by Florian Friesdorf (chaoflow) - Saturday, 24 October 2009, 02:00 GMT
From the kde "bug" report:
"the only things that have changed is that the icon is created a bit later in
the app startup (shouldn't matter one bit) and that the systray icon itself may
be deleted and re-created depending on what the host application does with it.
that kind of new/delete in the old protocol makes it easy to trigger race
conditions in system tray host implementations."

If it is a race condition, our approach so far won't work. If someone could give me some pointers I am happy to investigate. I would be most grateful to have kwalletmanager and korgac in my systray and am prepared to do some work to make it happen.
Comment by Uli Schlachter (psychon) - Sunday, 20 December 2009, 16:48 GMT
I use akregator and the systray icon works fine here:

Qt: 4.5.3
KDE: 4.3.2 (KDE 4.3.2)
Akregator: 1.5.1

awesome v3.4-96-gee9aa92 (Closing In)
• Build: Dec 18 2009 19:33:25 for x86_64 by gcc version 4.3.4 (psychon@psytux)
• D-Bus support: ?
Comment by Anton (fluffylime) - Friday, 25 December 2009, 22:10 GMT
I'm expiriencing this issue too. Klipper is in tray, but kmix is not...
Also, I've noticed that if I start KDE with Awesome as WM, bug is there, but if it is plain Awesome and I run Kmix, everything is fine.

Archlinux, KDE 4.3.4, Awesome-git(20091220).
Comment by Uli Schlachter (psychon) - Sunday, 14 March 2010, 15:09 GMT
Who still sees this?

If this bug were common, I would expect a lot more complaints. Does anyone still see this at all?
Comment by Thomas Koch (thkoch2001) - Monday, 15 March 2010, 09:58 GMT
I've not used awesome for some time because of this bug, but tried to reproduce it now. - Seems that the bug has vanished either in KDE or awesome.
Please don't close the bug yet. I'll switch back to awesome after the exam period and will do some more testing on this.
Comment by Thomas Koch (thkoch2001) - Saturday, 10 April 2010, 17:26 GMT
I've used awesome with some KDE apps now (all Debian unstable) for a good week and couldn't see the bug anymore.
Comment by Florian Friesdorf (chaoflow) - Monday, 12 April 2010, 13:44 GMT
It would be awesome, if you could say which exact versions that are (kde and awesome).
Comment by Thomas Koch (thkoch2001) - Monday, 12 April 2010, 14:33 GMT
awesome: 3.4.4-1
KDE, Kontact, Kopete, ...: 4:4.3.4-3
Comment by Florian Friesdorf (chaoflow) - Monday, 12 April 2010, 15:06 GMT
I still see the bug under Archlinux with:
awesome 3.4.4-1
kde 4.4.2-1
Comment by Florian Friesdorf (chaoflow) - Monday, 12 April 2010, 16:50 GMT
  • Task details edited
At least for me the bug did not vanish - see my last comment
Comment by Florian Friesdorf (chaoflow) - Saturday, 17 April 2010, 11:19 GMT
same with ubuntu lucid 10.4:
- kmix 4:4.4.2-0ubuntu3 (_not_ appearing in awesome's systray)
- klipper 4:4.4.2-0ubuntu13 (appearing in awesome's systray)
- awesome 3.4.3-1

% kmix --version
Qt: 4.6.2
KDE Development Platform: 4.4.2 (KDE 4.4.2)
KMix: 3.6

% klipper --version
Qt: 4.6.2
KDE Development Platform: 4.4.2 (KDE 4.4.2)
Klipper: v0.9.7

% awesome --version
awesome v3.4.3 (Engines)
• Build: Feb 2 2010 06:11:19 for x86_64 by gcc version 4.4.3 (buildd@yellow)
• D-Bus support: ?

Could gcc 4.4 vs 4.3 be guilty in some way?
Comment by Uli Schlachter (psychon) - Saturday, 12 June 2010, 20:01 GMT
Sorry, I got rid of all of my kde stuff when kde wanted to pull in mysql and some other weird stuff.
This means I won't be able to look into this, anyone else who would be able to shed some light on this?
Comment by Roman Kosenko (kite) - Thursday, 15 July 2010, 23:13 GMT
As for me, I dont' use a lot of KDE stuff, but all icons it seems like always appeared (awesome 3.4, KDE 4.4.5, archlinux), but there are other things with KDE applications icons in the tray - tooltips don't work, middle-click doesn't work and I can't see animated icons. It's woeful.
The other little trouble with tray - xxkb disappears after reloading awesome (but that's nothing, sometimes normal windows disappear).
Comment by Uli Schlachter (psychon) - Friday, 16 July 2010, 08:37 GMT
> As for me, I dont' use a lot of KDE stuff, but all icons it seems like always appeared (awesome 3.4, KDE 4.4.5, archlinux), but there are other things with KDE applications icons in the tray - tooltips don't work, middle-click doesn't work and I can't see animated icons. It's woeful.
Tooltips, middle-click and animated icons got nothing to do with awesome. The KDE app provides a window and awesome only places that window in the tray. Everything else has to be handled by the app via that window.

> The other little trouble with tray - xxkb disappears after reloading awesome (but that's nothing, sometimes normal windows disappear).
Not related to this bug, but both these bugs might be fixed in latest git version (both master and 3.4 branch). This should only ever happen if you dont shut down awesome cleanly, so how are you reloading awesome?
Comment by Roman Kosenko (kite) - Sunday, 25 July 2010, 12:28 GMT
> Tooltips, middle-click and animated icons got nothing to do with awesome. The KDE app provides a window and awesome only places that window in the tray. Everything else has to be handled by the app via that window.
That's good, but can you explain why does all this stuff work properly in stalonetray (http://stalonetray.sourceforge.net/)?

> This should only ever happen if you dont shut down awesome cleanly, so how are you reloading awesome?
"awesome.restart" from Lua. Sometimes "killall -HUP awesome" from shell - result the same. Are there others methods for reloading awesome?
In the git-version of 3.4 branch both problems still exist.

Regarding xxkb, I think, problem in window coordinates - xxkb window after restarting awesome appears on top-left conner and may overlapped by wibox. Please, see difference of xwininfo output before restarting and after:
% diff xxkb.xwininfo.old xxkb.xwininfo.new
4,7c4,7
< Absolute upper-left X: 672
< Absolute upper-left Y: 0
< Relative upper-left X: 72
< Relative upper-left Y: 0
---
> Absolute upper-left X: -440
> Absolute upper-left Y: -512
> Relative upper-left X: -440
> Relative upper-left Y: -512
22,23c22,23
< Corners: +672+0 -1224+0 -1224-1176 +672-1176
< -geometry 24x24-0+0
---
> Corners: +-440+-512 -2336+-512 -2336-1688 +-440-1688
> -geometry 24x24+-440+-512

Loading...