awesome

Welcome to awesome bug tracking system.
Tasklist

FS#606 - Clients with titlebars do not cover wibox in fullscreen

Attached to Project: awesome
Opened by anrxc (anrxc) - Friday, 28 August 2009, 15:00 GMT
Last edited by Uli Schlachter (psychon) - Tuesday, 17 August 2010, 16:10 GMT
Task Type Bug Report
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version git/master
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Hi,
thanks to the fixes for  FS#603  clients with titlebar can now be set maximized or fullscreen.

But there is an issue with the latter. When trying to set a floater, that has a titlebar, fullscreen it will not cover the wibox and titlebar will dissapear. So when I revert the fullscreen it gets the old size and titlebar is not _displayed_, but the client still acts like it is there (again not covering the wibox if set fullscreen) and I have to press my binding for titlebar toggle (and if I press it once more the titlebar is yet again displayed).
This task depends upon

Closed by  Uli Schlachter (psychon)
Tuesday, 17 August 2010, 16:10 GMT
Reason for closing:  Fixed
Additional comments about closing:  commit 6d1130b40812268ccb93add146da47c6e9904051
Author: Uli Schlachter <psychon@znc.in>
Date: Tue Aug 17 18:06:40 2010 +0200

Ignore the titlebar geometry on fullscreen clients

When a client is fullscreen, it should cover the full screen. There's no point
in trying to do clever things if the titlebar is banned anyway.

Signed-off-by: Uli Schlachter <psychon@znc.in>


Patch should be cherry-pickable onto older versions.
Someone will have to love me now. :)
Comment by anrxc (anrxc) - Friday, 28 August 2009, 15:05 GMT
I shouldn't have mentioned floating windows as it happens with all clients that have titlebars. On my desktop only floaters get one so I said it out of a habit. I could also add that I tried with placement.no_offscreen on and off.
Comment by anrxc (anrxc) - Tuesday, 29 September 2009, 22:29 GMT
Still a problem in 3.4-rc2, titlebar dissapears when a client is set fullscreen and to make it worse client is not truly fullscreen - wibox is visible, and can not be covered until a user forces removal of titlebar (that keybinding is not even present in default rc.lua).

Steps to reproduce, user enables titlebars in default rc.lua manage signal and hits Mod4+f on any client with a titlebar.
Comment by Radek (mseed) - Wednesday, 30 September 2009, 22:20 GMT
I have same problem in 3.4 rc2, titlebar after switching window (smplayer) to fullscreen in tiled mode dont cover wibox, after switching back from fullscreen titlebar disapear, i must switch to next tag and back and titlebar is back.
Comment by Alex Alexander (wired) - Wednesday, 11 November 2009, 00:24 GMT
Im having this issue as well, titlebars show OK, I maximize a window, titlebar disappears but top wibox is NOT covered, I restore window and titlebar is missing. Then I switch tags and window gets its titlebar again, but if I focus it the titlebar disappears again.

Happens with stock config as well as my custom one...
Comment by Alex Alexander (wired) - Wednesday, 11 November 2009, 00:25 GMT
forgot to mention I am using awesome 3.4.1
Comment by Alex Alexander (wired) - Wednesday, 11 November 2009, 00:33 GMT
* small correction * the titlebar doesn't disappear on focus now, that seems to be another issue, I'll have to look into it.

I still have this bug though. Fullscreen won't cover top wibox and you need to change tags to restore titlebar afterwards.
Comment by rom (rom) - Wednesday, 16 December 2009, 21:22 GMT
The wibox is covered (I put it on the bottom en the screen), it's the top of the screen that is not. The missing part is aproximately the height of a titlebar.
When un-maximizing, the tilebar of the un-maximized windows is not shown. It appears after changing tag, or opening a new window.
v. 3.4.2
Comment by anrxc (anrxc) - Tuesday, 12 January 2010, 00:14 GMT
When the client is set fullscreen the titlebar does not dissapear but goes off screen. The client however behaves like the titlebar is still on the screen so it does not resize to fill the whole available space - the gap is left where the titlebar would be. When fullscreen is reverted I can only assume that the titlebar is still somewhere off screen, when we switch tag focus it is reunited with the client.

I went trough some titlebar commits but I can't say when this went wrong, I hope someone else will know how to fix this.
Comment by Adam Nielsen (Malvineous) - Wednesday, 10 February 2010, 10:40 GMT
I just came across this too. Good to know it's possible to disable the titlebar with a keyboard shortcut to work around the issue.
Comment by Igor S. (ciphr) - Saturday, 31 July 2010, 13:40 GMT
Hmm, mplayer doesn't have a titlebar, but when titlebars are enabled in rc, the issue affects this app too. See  FS#792 

Loading...