awesome

Welcome to awesome bug tracking system.
Tasklist

FS#608 - Clients do not resize properly when an awful.rules floater appears

Attached to Project: awesome
Opened by anrxc (anrxc) - Friday, 28 August 2009, 15:46 GMT
Last edited by Julien Danjou (jd) - Tuesday, 22 September 2009, 13:57 GMT
Task Type Bug Report
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version git/master
Due in Version 3.4
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Hi,
since the titlebar problem from  FS#605  proved to be different then the issue with the floaters I am splitting it into another bug report.

When starting a client that is set as floating in awful.rules.rules the tiled clients that are already present make room for it but in most cases do not claim the free space once the new client is set as floating. First attached picture shows the issue.

Not only tiled clients will make room and re-arrange like it will get tiled but also the floating client keeps the size like it was suppsed to have if it would be tiled. That is very annoying because you have xmessage windows that say "bla" but can take up half of the screen. The second attached pictures shows the issue.

This task depends upon

Closed by  Julien Danjou (jd)
Tuesday, 22 September 2009, 13:57 GMT
Reason for closing:  Fixed
Additional comments about closing:  commit 9388dc5a1e45ffbdcfe0a94f2536f42bd91f2ebc
Author: Julien Danjou <julien@danjou.info>
Date: Tue Sep 22 15:56:58 2009 +0200

awful.client: fix initial geometry storage ( FS#608 )

Signed-off-by: Julien Danjou <julien@danjou.info>
Comment by Julien Danjou (jd) - Tuesday, 08 September 2009, 08:19 GMT
I'd need a way/patch to reproduce with defaut config.
Comment by Uli Schlachter (psychon) - Tuesday, 08 September 2009, 08:28 GMT
awful.layout registers some property signals in client::new and some of them are emitted before client::manage. Thus, at the time that client::manage (-> awful.rules) makes the client floating, it was already tiled by awful.layout which means the client keeps the tiled geometry

To reproduce: fair layout, 1 clients, start another one it will have half of the screen size. Again with 3 clients, the new one will have 1/4th of the screen size. Feel free to repeat with more clients

No idea on the "do not claim the free space once the new client is set as floating", afaik this didn't happen for me when I tried it

Uli
Comment by anrxc (anrxc) - Tuesday, 08 September 2009, 09:33 GMT
> No idea on the "do not claim the free space once the new client is set as floating"

It might be an Emacs problem, because I found now an interesting post about the new Emacs 23 under awesome http://bbs.archlinux.org/viewtopic.php?id=77213
Comment by anrxc (anrxc) - Tuesday, 08 September 2009, 09:51 GMT
Duplicate of this report is  FS#615 , that pretty much states what Uli said.
Comment by anrxc (anrxc) - Tuesday, 08 September 2009, 10:19 GMT
I can confirm that using a TrueType font in Emacs solves the problem of not claiming free space.
Comment by Cedric Gestes (ctaf) - Tuesday, 08 September 2009, 14:54 GMT
removing the tagged signal in awful/layout/init.lua remove the problem... but it's not the solution

Loading...