awesome

Welcome to awesome bug tracking system.
Tasklist

FS#67 - No rule to make target `awesome.1'

Attached to Project: awesome
Opened by Christian Gogolin (cgogolin) - Saturday, 09 February 2008, 15:43 GMT
Last edited by Julien Danjou (jd) - Monday, 11 February 2008, 13:39 GMT
Task Type Bug Report
Category Build system
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version git/master
Due in Version 2.2
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Today I tried to compile the git version of awesome.

After installing all Dependencies and a successful execution of "autogen.sh" and "configure" "make" quits with the following error message:

make all-am
make[1]: Entering directory `/home/cgogolin/data/coding/c++/projects/awesome'
make[1]: *** No rule to make target `awesome.1', needed by `all-am'. Stop.
make[1]: Leaving directory `/home/cgogolin/data/coding/c++/projects/awesome'
make: *** [all] Error 2

In fact, the Makefile does not include a rule to make "awesome.1".

The target "all-am" depends on the files in listed in $(MANS), namely

awesome.1 awesome-client.1 awesomerc.1 .

The folder pulled via git does not include this files, but does include the files

awesome.1.txt awesome-client.1.txt awesomerc.1.txt ,

Removing the .txt extension makes "make" run without complains.
This task depends upon

Closed by  Julien Danjou (jd)
Monday, 11 February 2008, 13:39 GMT
Reason for closing:  Fixed
Additional comments about closing:  Hans pushed patches for ignoring manpages on asciidoc/xmlto missings.
Comment by Julien Danjou (jd) - Saturday, 09 February 2008, 17:31 GMT
This is not a bug, you need asciidoc and xmlto to build documentation. See README.

I keep this open until ndim come with a patch to stop make complaining about this or configure to cry out if xmlto/asciidoc are not present. ;-)
Comment by Zsolt Udvari (uzsolt) - Saturday, 09 February 2008, 18:25 GMT
If you don't want to install asciidoc or xmlto then you can "patch" makefile (after ./configure) with this command:

sed -i "s@man_MANS =.*@man_MANS =@g" Makefile
Comment by Christian Gogolin (cgogolin) - Saturday, 09 February 2008, 19:32 GMT
I must confess that it was my fault...

I installed "xmlto" and "ascidoc" after my first attempt to compile awesome and forgot to run "autogen" again.

I'm very sorry for having bothered you with this!

Loading...