awesome

Welcome to awesome bug tracking system.
Tasklist

FS#74 - Firefox 3.0b3 "shakes" unless full screen

Attached to Project: awesome
Opened by Henrik Olsson (henrik) - Thursday, 21 February 2008, 14:03 GMT
Last edited by calmar (calmar) - Sunday, 16 March 2008, 13:26 GMT
Task Type Bug Report
Category Core
Status Closed
Assigned To No-one
Operating System Linux
Severity Very Low
Priority Normal
Reported Version 2.2-rc1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

If firefox 3.03b3 needs to share screen space with another window, i.e. unless it's the only window on a tag or layout is full screen, the web page area in firefox "shakes", as if firefox tries to re-layout it continously.

I haven't seen this behaviour in any program, and i have not tried another version of firefox.

Perhaps this is not a bug in awesome but in firefox.
This task depends upon

Closed by  calmar (calmar)
Sunday, 16 March 2008, 13:26 GMT
Reason for closing:  Works for me
Additional comments about closing:  can't reproduce.
Comment by calmar (calmar) - Sunday, 02 March 2008, 08:26 GMT
so in this setup it should shake?
http://www.calmar.ws/tmp/122-Sun-screen.png
here nothing like that is the case.

git-awesome and 4bpre firefox
Comment by Henrik Olsson (henrik) - Monday, 03 March 2008, 08:02 GMT
Well, the pattern for me seems to be that it happens any time firefox is not given 100% of the width of the screen.. so yes, that should shake.
My resolution is 1280x1024.

Is there any way i can give you more to go on?
Comment by calmar (calmar) - Monday, 03 March 2008, 11:57 GMT
i have the same resolution.

maybe updating ffox + awesome to the git version especially.

http://git.naquadah.org/?p=awesome.git;a=summary there you can download a tarball, or
git-clone git://git.naquadah.org/awesome.git should work too. directing directly to
that new built awesome binary in .xinitrc or however - then you don't even have to actually 'install' it.

then a screenshot or even a 'recordmydesktop' of that behaviour when it's still there.

cheers

Loading...