awesome

Welcome to awesome bug tracking system.
Tasklist

FS#75 - after closing tvbrowser (java program) no keyboard handling anymore

Attached to Project: awesome
Opened by calmar (calmar) - Tuesday, 26 February 2008, 08:29 GMT
Last edited by calmar (calmar) - Sunday, 22 February 2009, 03:17 GMT
Task Type Bug Report
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Very Low
Priority Low
Reported Version git/master
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

When I open a java program like 'tvbrowser'

looks like that:
http://www.calmar.ws/tmp/103-Tue-screen.png

then I close it. So when that was the only application (-> empty screen after that), I can't do things with the keyboard anymore.

(as if something catches all keyboard events.). I have to use the mouse to do something then.

I open it like this:
#!/bin/bash
export AWT_TOOLKIT=MToolkit
cd /home/calmar/bin/tvbrowser-2.6.3/
/home/calmar/bin/jre1.6.0_03/bin/java -jar tvbrowser.jar

really nothing severe, but still something to solve one day.
This task depends upon

Closed by  calmar (calmar)
Sunday, 22 February 2009, 03:17 GMT
Reason for closing:  Works for me
Additional comments about closing:  with latest awesome (awesome) v3.2-rc3 (Chocolate). Probably also somebit earlier. I could bisect if there is some interest.
Comment by calmar (calmar) - Thursday, 28 February 2008, 08:56 GMT
I can reproduce this only with tvbrowser. I tried it with two other java programs (one of them jin chess), but there was not this kind of problem.

I don't think I can figure that out myself. So just in case:
http://www.tvbrowser.org/content/view/7/6
there the tvbrowser-2.6.3.tar.gz can get downloaded.
Comment by calmar (calmar) - Monday, 21 April 2008, 00:55 GMT
Unfortunately, that's also the case on awesome-3 (I had some hope...)
Comment by calmar (calmar) - Saturday, 10 May 2008, 03:45 GMT
calmar@tuxli:~/packets/awesome$ git-bisect good
485614f2df7f90b8d4a2fe8740c7b2686166b393 is first bad commit
commit 485614f2df7f90b8d4a2fe8740c7b2686166b393
Author: Julien Danjou <julien@danjou.info>
Date: Fri Jan 25 12:55:44 2008 +0100

rewrite focus handling

- arrange() does not focus() anymore
- restore dropping events infra
- add client_unfocus()
- grabbuttons() where we should and add root_grabbuttons() for root window

:100644 100644 4c3b3317fa41d236b15663d7e98a9aa267abc424 1438c6c6dde25406ea021155d256b88b74892945 M awesome.c
:100644 100644 3663a68a16ff000d0e77958748eac3a7c84fabfc 5ad9814fc4785f93cb6e394f575f5f24b091e20b M client.c
:100644 100644 543e8dbb6b2bb5966ad24fdd9ffe7293ce234827 599033c81443568d57217322814a917bb136a477 M event.c
:100644 100644 4e11b9c81162f2b1c03535d47acfb69467b1ce2e 50ba141c4d802bb50bf3b96be31431b2a4c3410b M layout.c
:100644 100644 90a8f83016ce36ef2cbaf5b6a1ff4ebc8a566c4a 9a81c39ea50c4378bd47dcbd73cc5ef591cf5bcd M layout.h
:100644 100644 4fac9afd69cd748b79cd25a54361d159eb8ab0d3 3132f0edefe047a63e156c324439ef5647f45a42 M structs.h
:100644 100644 90392ca26f9e94914b668fd79a9cd4cf4297c6f8 edfbf3d70f5a451b7378fdb1368b98e05288ff11 M window.c
:100644 100644 d5cf9116ebfaec5d85a275f586be43d67e211609 3fff3348e25cf62745001cf3ac27883ed685c201 M window.h
Comment by calmar (calmar) - Saturday, 10 May 2008, 12:23 GMT
and there, not removing following - lines seems to allow keyhandling after closing tvbrowser again (fixing it or so):

diff --git a/layout.c b/layout.c
index 4e11b9c..50ba141 100644
--- a/layout.c
+++ b/layout.c
@@ -57,9 +57,6 @@ arrange(int screen)
{
Client *c;
Layout *curlay = get_current_layout(screen);
- Window client_win, root_win;
- int x, y, d;
- unsigned int m;

for(c = globalconf.clients; c; c = c->next)
{
@@ -77,33 +74,28 @@ arrange(int screen)
{
c->newcomer = False;
client_unban(c);
+ if(globalconf.screens[screen].new_get_focus)
+ focus(c, screen);
}

if(!globalconf.screens[screen].allow_lower_floats)
layout_raise_floatings(screen);

- c = focus_get_current_client(screen);
- focus(c, screen);
- if(c && XQueryPointer(globalconf.display, RootWindow(globalconf.display, get_phys_screen(screen)),
- &root_win, &client_win, &x, &y, &d, &d, &m) &&
- (root_win == None || client_win == None || client_win == root_win))
- window_grabbuttons(c->screen, c->win, False, False);
-
/* reset status */
globalconf.screens[screen].need_arrange = False;
}
Comment by calmar (calmar) - Saturday, 10 May 2008, 12:34 GMT
but, something like this exists on the HEAD of master branch.
Comment by calmar (calmar) - Saturday, 10 May 2008, 18:31 GMT
therefore ignore that thing, it's wrong anyway. But still seems to be the case: that commit introduces it.
Comment by Julien Danjou (jd) - Friday, 26 September 2008, 15:14 GMT
Is this bug still happening to you?
Comment by calmar (calmar) - Friday, 26 September 2008, 21:33 GMT
Yep, it does. I try to hunt it down in winter or so..

Loading...