awesome

Welcome to awesome bug tracking system.
Tasklist

FS#755 - fullscreened flash videoplayer overlay stays after killing flashplayer

Attached to Project: awesome
Opened by andy (fiegepils) - Sunday, 04 April 2010, 17:39 GMT
Last edited by Uli Schlachter (psychon) - Tuesday, 25 May 2010, 18:25 GMT
Task Type Bug Report
Category Core
Status Closed
Assigned To No-one
Operating System Linux
Severity High
Priority Normal
Reported Version 3.4.4
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

description:
The overlay of a fullscreened flash application freezes, covering the whole screen. It does not disappear after terminating flash/the browser. The windows that lie beneath are still responsive, the functionality of bindings etc. does not seem to be inhibited. They just can't be seen because they are covered by the frozen flash overlay.
Reloading the windowmanager does not help. X has to be restarted entirely.

reproduce:
Go to youtube and fullscreen a paused video. Then switch to a different tag via keybinding. Now the overlay should still be there, covering the entire screen.

I am running awesome-3.4.4 on a gentoo system, compiled with gcc-4.4.3, using the adobe 64bit flashplayer-10.0.45.2 on firefox-3.6.2. I first encountered this problem after I set size_hints_honor to false, so this might be related.
This task depends upon

Closed by  Uli Schlachter (psychon)
Tuesday, 25 May 2010, 18:25 GMT
Reason for closing:  Works for me
Additional comments about closing:  Unreproducible
Comment by Uli Schlachter (psychon) - Monday, 05 April 2010, 09:12 GMT
It's flash, what did you expect? ;)

Works fine here, went to youtube, started a random video, paused it immediately, "full"screened it (I got huge black borders around the video, I wouldnt call that fullscreen) and switched to a different tag. When switiching back, the player had switched back to the normal, embedded view.
Anything I'm doing wrong?
Comment by lotus (lotus) - Monday, 19 April 2010, 12:00 GMT
i can confirm your problem Uli. i have the same issues
Comment by Uli Schlachter (psychon) - Monday, 19 April 2010, 13:56 GMT
lotus: I don't have any issue, so does that mean the issue is having no issue?

From the reporter's description, this doesn't seem to be awesome-related to me (the "death" flash overlay does survive awesome restarts), so can we just close this? (Does it happen with other WMs, too?)
Comment by anrxc (anrxc) - Monday, 19 April 2010, 17:27 GMT
I've been seeing the same problem, loosing my work often... we should figure out what we have in common, us few that can trigger this problem. Intel graphics? Flash version?
Comment by anrxc (anrxc) - Monday, 19 April 2010, 17:28 GMT
My last freeze was making this presentation fullscreen, http://www.slideshare.net/itshowoff/dinko-koruni-skalabilna-web-rjeenja-it-showoff I use flash 10.0.45.2, with intel graphics.
Comment by Uli Schlachter (psychon) - Monday, 19 April 2010, 17:50 GMT
Flash identifies itself as 10.0 r45 (I just apt-get install'd flasgplugin-nonfree on my debian testing), box is amd64, two screens, intel graphics ("Mobile 4 Series Chipset"). Browser is uzbl, haven't tried with firefox.

Oh and of course: I can NOT reproduce.
Comment by anrxc (anrxc) - Monday, 19 April 2010, 22:41 GMT
Right, are we all Arch Linux users?
Comment by anrxc (anrxc) - Monday, 03 May 2010, 20:46 GMT
Probably an intel driver bug, just found this https://bugs.freedesktop.org/show_bug.cgi?id=26937
Comment by Uli Schlachter (psychon) - Tuesday, 04 May 2010, 13:47 GMT
That intel bug says that the X server freezes completely while the reporter only mentions a black overlay window that doesn't want to disappear.
Comment by anrxc (anrxc) - Wednesday, 19 May 2010, 22:54 GMT
Uli,
some comments mention the same thing. What's more the problem seems to be elevated, started as an overlay, but then started hard freezing the OS. Bottom line, looked like it's not an awesome bug.

I am now running awesome 3.4.5. I have Linux 2.6.34, xf86-video-intel-git 20100429 and flashplugin 10.0.45.2. I've been watching videos fullscreen (also 1080p) the whole day and can no longer reproduce the problem.
Comment by Uli Schlachter (psychon) - Thursday, 20 May 2010, 15:50 GMT
Anyone can still reproduce this? If not, I guess we should close this and blame the X server.

Loading...