awesome

Welcome to awesome bug tracking system.
Tasklist

FS#763 - Okular PDF presentation does not cover the wibox

Attached to Project: awesome
Opened by anrxc (anrxc) - Friday, 07 May 2010, 00:13 GMT
Last edited by Uli Schlachter (psychon) - Friday, 07 May 2010, 18:44 GMT
Task Type Bug Report
Category Core
Status Closed
Assigned To Uli Schlachter (psychon)
Operating System Linux
Severity Low
Priority Normal
Reported Version git/3.4
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 1
Private No

Details

Hi,
I noticed Okular does not cover the wibox. I removed the titlebar thinking it was bug  FS#606  but it is not. Presentation does not expand to the full screen even when wibox is not visible (visible = false). The xprop and xwininfo are attached, maybe Uli sees something.
This task depends upon

Closed by  Uli Schlachter (psychon)
Friday, 07 May 2010, 18:44 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Duplicate of  FS#606 
Comment by Uli Schlachter (psychon) - Friday, 07 May 2010, 15:02 GMT
Nice, didn't know okular could do that.

Works flawlessly here (git master) with wibox visible, could you also give us xprop -root of when this happens? Which awesome version are you on exactly?
Comment by anrxc (anrxc) - Friday, 07 May 2010, 15:13 GMT
Hey Uli,
it's git/3.4 as stated in the report, built from snapshot of your
commit "Use WM_STATE_NORMAL as default". KDE is 4.4.3 which makes
Okular version 0.10.3.

Requested xprop output attached.

Comment by Uli Schlachter (psychon) - Friday, 07 May 2010, 17:37 GMT
According to okular's xprop output, it is "fullscreen" and "above" at the same time. According to the code, this should be impossible (no idea why, however).

And for reference, I'm using kde 4.3.4 and okular 0.9.4. No idea what to do now, only thing which comes to my mind is "wait for Uli to get a newer kde version", sorry.
Comment by anrxc (anrxc) - Friday, 07 May 2010, 18:19 GMT
Hey Uli,
something you said got me thinking... about the window being above - that is thanks to a piece of code I use to keep all floaters above (yes, it happens without that code too). But then I realized I always tried this with Okular floating (I read on tag 9, floating tag).

Now I tried it on a tile layout and it did cover the wibox. Can you try on a floating layout?
Comment by Uli Schlachter (psychon) - Friday, 07 May 2010, 18:32 GMT
Nope, still works on a floating layout
Comment by anrxc (anrxc) - Friday, 07 May 2010, 18:40 GMT
Yes, because it turns out this is after all a duplicate of  FS#606  - I have another piece of custom code that adds a titlebar to every floating client. Somehow when presentation mode is enabled Okular sends some hint or something and triggers the titlebar adding, the titlebar does not get displayed (this my initial confusion) but the  bug 606  is triggered.

So, a duplicate of  FS#606 .

Loading...