awesome

Welcome to awesome bug tracking system.
Tasklist

FS#799 - Libpng version detection on Slackware64 13.1

Attached to Project: awesome
Opened by Conrad Buck (conartist6) - Monday, 16 August 2010, 17:37 GMT
Last edited by Uli Schlachter (psychon) - Monday, 16 August 2010, 17:41 GMT
Task Type Bug Report
Category Build system
Status Closed
Assigned To No-one
Operating System Linux
Severity Low
Priority Normal
Reported Version 3.4.5
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

I am trying to compile and run awesome 3.4.6 on Slacware64 13.1. I have previously had awesome running perfectly on this system, and only recently did upgraded to the newest version of slackware. The problem is that after awesome successfully compiles, I get the following error while trying to run it:

"libpng warning: Application was compiled with png.h from libpng-1.2.37"
"libpng warning: Application is running with png.c from libpng-1.4.3"
"libpng warning: Incompatible libpng version in application and library"

loads its background but gets no further, console output indicates that it has failed while trying to load the first PNG icon it comes upon.

The obvious problem is that Slackware 13.1's libpng package includes two versions of that library (the two versions the error above mentions) for compatibility reasons.

Since I started looking into the reasons for this problem I have found that awesome does not support libpng 1.4. This leads me to believe that I could eliminate the problem by linking my default libpng.so to libpng12.so instead of libpng14.so, but obviously this would be bad news for every other program. Instead I have tried using a_find_library to save the library path to a variable, and then using ccmake to edit the library path before the program is compiled, but that doesn't seem to work. Perhaps i am not using the results of that variable correctly? So far I only added two lines:
+ a_find_library(LIB_PNG png)
and
${LIB_PNG}
in the
set(AWESOME_REQUIRED_LIBRARIES...
section.

Here is my awesomeConfig.cmake file.

As far as I know, it should be possible to recreate this bug simply by trying to compile awesome on slackware 13.1
This task depends upon

Closed by  Uli Schlachter (psychon)
Monday, 16 August 2010, 17:41 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Awesome doesn't use libpng (directly). Most likely your imlib2 is broken.
Comment by Conrad Buck (conartist6) - Monday, 16 August 2010, 17:42 GMT
Apologies, I misread at a glance. Seems awesome IS compatible with libpng's 1.2 and 1.4, so it needs to set its mind straight in this situation.

Loading...