awesome

Welcome to awesome bug tracking system.
Tasklist

FS#822 - croping images

Attached to Project: awesome
Opened by Roman Kosenko (kite) - Saturday, 18 September 2010, 01:40 GMT
Last edited by Uli Schlachter (psychon) - Saturday, 18 September 2010, 07:39 GMT
Task Type Bug Report
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version git/master
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

I think everybody who use awesome noticed garbage pixels on buttons when press it. That's because img_release:crop(-2, -2, img_release.width, img_release.height) returns incorrect image - function imlib_create_cropped_image() of imlib2 doesn't initialize buffer for new image. Please, read this:
http://trac.enlightenment.org/e/ticket/477
This task depends upon

Closed by  Uli Schlachter (psychon)
Saturday, 18 September 2010, 07:39 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Duplicate of  FS#516 . There you'll also find out that it was me who openned that bug reported for imlib2.
Comment by Roman Kosenko (kite) - Saturday, 18 September 2010, 02:15 GMT
suggested patch
Comment by Uli Schlachter (psychon) - Saturday, 18 September 2010, 07:45 GMT
Could you please subsribe to  FS#516 ?

Also, for your patch:
You seem to be using git. Instead of sending us the output of "git diff", use "git commit -as" to commit your change (enter some commit message that describes the change( and "git format-patch HEAD~1.." to get a file to send to us. That makes sure that you'll be tracked as the author of this.

Do I understand correctly that imlib_context_set_blend(0); means that imlib will directly replace the color in the target pixels instead of doing the "normal" alpha compositing? Also, I guess you should imlib_context_set_blend(1); when you are done.


Thanks a lot for this patch, I didn't know this was possible at all!
Comment by Roman Kosenko (kite) - Saturday, 18 September 2010, 21:18 GMT
> Do I understand correctly that imlib_context_set_blend(0); means that imlib will directly replace the color in the target pixels instead of doing the "normal" alpha compositing?
You are right, this turns off alpha compositing.

> I guess you should imlib_context_set_blend(1); when you are done.
Ok, let's add. But I would prefer setup blending option *before* operation it require.

> Instead of sending us the output of "git diff", use "git commit -as" to commit your change (enter some commit message that describes the change( and "git format-patch HEAD~1.." to get a file to send to us.
Difference only in comment and author notice? This isn't important at all.

Loading...