awesome

Welcome to awesome bug tracking system.
Tasklist

FS#847 - notifications appear only at default position

Attached to Project: awesome
Opened by anna (ruda) - Friday, 19 November 2010, 00:44 GMT
Last edited by Julien Danjou (jd) - Friday, 28 January 2011, 13:32 GMT
Task Type Bug Report
Category Lua libraries → naughty
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version 3.4.8
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When I launch /usr/bin/notification-properties or set naughty position in rc.lua, I get notifications only in the default top right corner despite the notify-send properties or naughty properties set in config.

If I execute something like
echo 'naughty.notify({title = "testing", text = "naughty", position = "top_left"})' | awesome-client -
I get notification int the top left corner as I specified.

If I edit /usr/share/awesome/lib/naughty.lua and change "top_right" to "bottom_right" at line 289
local position = args.position or preset.position or "top_right"
I will get all notifications in the bottom right corner.

I think, something is wrong
This task depends upon

Closed by  Julien Danjou (jd)
Friday, 28 January 2011, 13:32 GMT
Reason for closing:  Works for me
Comment by Uli Schlachter (psychon) - Saturday, 20 November 2010, 09:38 GMT
What's /usr/bin/notification-properties? How does it work? Which package is it a part of?

Why is something wrong when you change "top_right" into "bottom_right" and now notifications are in the bottom right? Isn't that exactly what should be happening?
Comment by anna (ruda) - Saturday, 20 November 2010, 11:19 GMT
notification-properties is a part of notify-send

it is all right with it. the problem is that if i use notify-send or set a naughty position in rc.lua, i get notifications in the default corner *only*, despite the settings
Comment by Uli Schlachter (psychon) - Saturday, 20 November 2010, 12:50 GMT
Sorry, at least on debian testing notification-properties is not part of notify-send.

$ dpkg -S /usr/bin/notify-send
libnotify-bin: /usr/bin/notify-send
$ dpkg -L libnotify-bin | grep -i prop
$ locate notification-properties
$
Comment by Uli Schlachter (psychon) - Saturday, 20 November 2010, 12:51 GMT
Also, your "setting" is wrong. If you want all notification to be forced into some corner, you'd have to replace that line in naughty.lua with:

local position = "top_right"

Loading...