awesome

Welcome to awesome bug tracking system.
Tasklist

FS#851 - Crashing with multitail

Attached to Project: awesome
Opened by Oleg Kulabukhov (olegon) - Saturday, 04 December 2010, 09:18 GMT
Last edited by Uli Schlachter (psychon) - Saturday, 04 December 2010, 11:54 GMT
Task Type Bug Report
Category Core
Status Closed
Assigned To No-one
Operating System Linux
Severity Critical
Priority Normal
Reported Version 3.4.8
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Linux oops 2.6.34-gentoo-r12 #3 SMP Sat Nov 13 15:15:34 MSK 2010 x86_64 Intel(R) Core(TM)2 Duo CPU E8600 @ 3.33GHz GenuineIntel GNU/Linux

olegon@oops ~ $ awesome -v
awesome v3.4.8 (Never Know)
Build: Dec 2 2010 17:09:26 for x86_64 by gcc version 4.4.4 (@oops)
D-Bus support: yes
-------
How to reproduce:
create script file as follows

#!/bin/bash
multitail /some/path/to_log/access.log

using multitail 5.2.2 and try to run this script by mod4-r /path/to/script.sh
Boom.. Awesome crashes to logon screen.
Tried many times, crashes only with multitail every run and only in mod4-r, so I can run script by run urxvt and than multitail in it.
This task depends upon

Closed by  Uli Schlachter (psychon)
Saturday, 04 December 2010, 11:54 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Awesome doesn't crash. multitail kills awesome.

multitail does this before existing:
kill(0, SIGTERM);

man page says " If pid equals 0, then sig is sent to every process in the process group of the calling process."
Comment by Uli Schlachter (psychon) - Saturday, 04 December 2010, 12:23 GMT
Meh, although I don't think this is awesome's fault, I did something about it:

commit f05dabd76eed11b002135cbe8f11a136146e644e
Author: Uli Schlachter <psychon@znc.in>
Date: Sat Dec 4 13:19:01 2010 +0100

spawn: Create sessions for processes ( FS#851 )

Each process spawned from awesome now gets its own session and process group.
This makes sure they aren't connected to awesome in any way any more. This
especially fixes some problems with signals.

Signed-off-by: Uli Schlachter <psychon@znc.in>

Loading...