awesome

Welcome to awesome bug tracking system.
Tasklist

FS#860 - awful.widget.prompt does not support higher keyboard levels

Attached to Project: awesome
Opened by Gereon Kaiping (gk230-awesome) - Friday, 14 January 2011, 00:08 GMT
Last edited by Julien Danjou (jd) - Friday, 28 January 2011, 13:29 GMT
Task Type Bug Report
Category Widgets
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version 3.4.8
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I use a keyboard layout (http://neo-layout.org) with more than two (i.e. capital and small letters) levels, and e.g. my "\" and "/" lie on level three.

awful.widget.prompt just recognizes levels one (no additional key pressed) and 2 (shift key pressed), but not any further levels.

(This is especially annoying for me in connection with FS#859, because it means that I cannot run commands or access files from the prompt that reside in directories that need escaping.)

[I have this bug for awesome 3.4.4 on gentoo with the neo2 keyboard layout and did not yet try any other configuration.]
This task depends upon

Closed by  Julien Danjou (jd)
Friday, 28 January 2011, 13:29 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#303 

Loading...