awesome

Welcome to awesome bug tracking system.
Tasklist

FS#867 - Crazy focus toggle with chromium

Attached to Project: awesome
Opened by Vitja Makarov (vitja) - Saturday, 05 February 2011, 12:49 GMT
Last edited by Uli Schlachter (psychon) - Sunday, 06 February 2011, 17:02 GMT
Task Type Bug Report
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity High
Priority Normal
Reported Version 3.4.8
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I'm running chromium browser and awesome 3.4.9.

When chroimum window is maximized and mouse is at screen boundary.
Window focus starts toggling fast and awesome takes about 100% cpu.
This task depends upon

Closed by  Uli Schlachter (psychon)
Sunday, 06 February 2011, 17:02 GMT
Reason for closing:  Works for me
Additional comments about closing:  Can't reproduce.

I installed chromium-browser 6.0.472.63~r59945-5 from debian testing, started awesome with the default config in Xephyr and opened an urxvt (so there is something that it can "toggle" the focus to). Then I opened chromium and fullscreen'd it via mod1+m (I changed modkey to "mod1"). It was fullscreen'd. Then I moved the mouse pointer to the left screen edge. Nothing happened.
Comment by Uli Schlachter (psychon) - Saturday, 05 February 2011, 12:59 GMT
"Mouse is at screen boundary" <- So you have two monitors, chromium is on e.g. the left one and the mouse points at some point in the middle of both screens?

Could you set a larger border_width (e.g. 20) in your theme and check if this happens when the mouse points at the window border / just outside of the window / just inside of the window?
Comment by Uli Schlachter (psychon) - Saturday, 05 February 2011, 13:00 GMT
Oh, also: what exactly do you mean by "maximized"?
Comment by Vitja Makarov (vitja) - Saturday, 05 February 2011, 13:07 GMT
> "Mouse is at screen boundary" <- So you have two monitors, chromium is on e.g. the left one and the mouse points at some point in the middle of both screens?

No one monitor, window is maximized using Mod4-m (it uses all available space),
and mouse pointer is at (0, y) for example.

May be the problem is that chromium window is wm-titlebar-less?

Loading...