awesome

Welcome to awesome bug tracking system.
Tasklist

FS#905 - urxvt in 32-bit color depth doesn't have active window border.

Attached to Project: awesome
Opened by David J. Haines (dhaines) - Monday, 16 May 2011, 20:31 GMT
Last edited by Uli Schlachter (psychon) - Thursday, 12 April 2012, 20:06 GMT
Task Type Bug Report
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version 3.4.10
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

I hate to be the first one to report a bug in 3.4.10, but here goes:

Unicode-rxvt (a.k.a. urxvt) doesn't get its border when active if the depth: 32 resource is set on it. It doesn't matter whether there's actually any alpha used or whether there's a compositing manager running, once that depth goes to 32, it loses the border. If xcompmgr is running, you get a one-pixel wide border at all times that doesn't light on active and if it isn't, you just get your window, but without either frame or active border at all.

This is on current Arch Linux.
This task depends upon

Closed by  Uli Schlachter (psychon)
Thursday, 12 April 2012, 20:06 GMT
Reason for closing:  Fixed
Additional comments about closing:  Oh, this is fixed ever since git/master was turned into a reparenting WM. Which was qutie a while ago.
Comment by Uli Schlachter (psychon) - Monday, 16 May 2011, 20:37 GMT
/me stabs

I don't actually think this is a new bug. If a window has a 32 bit depth, the window border has to be set with a 32 bit depth, too. Awesome only uses the default visual which most likely is a 24bpp one. So the window border awesome sets has an alpha of 0.

Are you sure that this worked in older versions?
Comment by David J. Haines (dhaines) - Monday, 27 June 2011, 08:37 GMT
  • Field changed: Percent Complete (100% → 0%)
psychon seems to agree that this is, in reality, a bug. I thought that it was a new bug, but it seems that it's really an old one.

Re-open it if you want. It doesn't impair the use of awesome that much.
Comment by Uli Schlachter (psychon) - Monday, 27 June 2011, 08:38 GMT
 FS#910  is a duplicate of this
Comment by Ignas Anikevicius (gns_ank) - Thursday, 12 April 2012, 19:48 GMT
Isn't this fixed in git/master by
http://git.naquadah.org/?p=awesome.git;a=commit;h=00059d2d73009883ad666c44d2449004fff2257e
?

I do not know, whether the person that reported wanted to be able to set a 32-bit colour for borders as well, but if all is good with the commit above, I think that this bug can be closed.

I.

Loading...