awesome

Welcome to awesome bug tracking system.
Tasklist

FS#927 - Cannot make if your hostname contains space

Attached to Project: awesome
Opened by Morten (Ninn) - Friday, 23 September 2011, 17:24 GMT
Last edited by Gregor Best (farhaven) - Friday, 23 September 2011, 17:42 GMT
Task Type Bug Report
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version git/master
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Awesome failed to build on arch linux box, from AUR

Host name was 'Rainbow Dash'
got the following error:
Failed to make:
Dash-x86-64-unknown-linux-gnu-4.6.1

Changed hostname to 'RainbowDash' and it compiled fine
This task depends upon

Closed by  Gregor Best (farhaven)
Friday, 23 September 2011, 17:42 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Spaces are not valid in hostnames. See RFC-1123, Section 2.1 and RFC-952, assumption 1. Hostnames must not contain characters other than those in the class [a-aA-Z0-9.-]. I'm surprised Arch actually allows setting invalid hostnames...

Loading...