awesome

Welcome to awesome bug tracking system.
Tasklist

FS#949 - When try to move/resize window of gnome-terminal by mouse, mouse stops working

Attached to Project: awesome
Opened by Andrew Inishev (inish777) - Tuesday, 13 December 2011, 16:07 GMT
Last edited by Julien Danjou (jd) - Friday, 01 June 2012, 11:38 GMT
Task Type Bug Report
Category Core
Status Closed
Assigned To No-one
Operating System Linux
Severity High
Priority Normal
Reported Version git/master
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

In my case, mouse stops working when i try to move/resize window of gnome-terminal. I can move mouse, but all apps(not only gnome-termonal) don't response on mouse clicks. When i kill gnome-terminal, mouse begin to working again.
This task depends upon

Closed by  Julien Danjou (jd)
Friday, 01 June 2012, 11:38 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Seems like not a bug + already fixed.
Comment by Uli Schlachter (psychon) - Tuesday, 13 December 2011, 21:24 GMT
This seems to be a general problem with gtk3. Symptoms sounds like gnome-terminal grabs the mouse. However, no idea why it would do that.
Comment by Uli Schlachter (psychon) - Saturday, 07 April 2012, 17:54 GMT
Does anyone still sees?

Google gave me https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/878859 and that suggests that this was/is a gtk+3 bug and not awesome's fault.
Comment by Alexander Yakushev (Alex.yakushev) - Wednesday, 23 May 2012, 22:35 GMT
Couldn't reproduce, awesome git/master, gnome-terminal-3.4.1.1-1.

I guess it is over now.

Loading...