awesome

Welcome to awesome bug tracking system.
Tasklist

FS#956 - In awful.tooltip, update geometry after set_text

Attached to Project: awesome
Opened by Can Altıparmak (c6dev) - Monday, 02 January 2012, 16:13 GMT
Last edited by Uli Schlachter (psychon) - Sunday, 04 November 2012, 20:54 GMT
Task Type Evolution Request
Category Lua libraries → awful
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version 3.4.11
Due in Version 3.5
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

In awful.tooltip, timer_function calls set_text to update widget and afterwards set_geometry to update tooltip geometry.

If timer_function is not set and tooltip is updated with only "set_text", when tooltip is already visible, since wibox geometry is not updated, text overflows. You must hover out and in to force a geometry update.
So either:
- make set_geometry global
or better
- call set_geometry within set_text
(it is reasonable, because only place set_text ever called in tooltip.lua is within timer_function, and it is followed by a call to set_geometry)
This task depends upon

Closed by  Uli Schlachter (psychon)
Sunday, 04 November 2012, 20:54 GMT
Reason for closing:  Fixed
Additional comments about closing:  commit 4711354b5d666c1bf2da90e0ae1c97f0d67ea631
Author: Uli Schlachter <psychon@znc.in>
Date: Sun Nov 4 21:53:38 2012 +0100

awful.tooltip: Update geometry in set_text ( FS#956 )
Comment by Jörg Thalheim (Mic92) - Friday, 13 January 2012, 15:58 GMT
I experienced the same problem, when I scroll in my calendar from a month with more days then the old one.
Comment by Uli Schlachter (psychon) - Saturday, 03 November 2012, 19:17 GMT
No one mentioned an easy way to reproduce this and I am too lazy to come up with one by my own, so:

Could someone test the attached patch?

Loading...